Getting Data In

Add monitor file with new index not working

tanglong
Engager

Hello,

I have problem with Splunk Forwarder.

Currently, i monitor a dir (/var/log/httpd/*) but it automatic delete old log and insert new log. Index default is "main".

I want to store with new index name "weblog", i have do:
- Step 1: delete all log httpd with search query: "source=httpd | delete"
- Step 2: remove old monitoring and add new: ./splunk add monitor "/var/log/httpd/*" -index weblog -sourcetype newsource

But it not working.

I use command below it working but not define new index: ./splunk add monitor "/var/log/httpd/*" -sourcetype newsource

Can you help me resolve my problem?
Thanks.

Tags (2)
0 Karma
1 Solution

gcusello
SplunkTrust
SplunkTrust

Hi tanglong,
when you already ingested logs from a file you cannot ingest them again, also renaming the file.
To do this you have to use a workaround:

  • delete the old logs from the main index using the delete command, remember that only special users (can_delete role) can delete logs, this step isn't mandatory;
  • create the new index weblog on Indexer
  • modify inputs.conf on Forwarder adding the option index = weblog to inputs.conf;
  • modify inputs.conf on Forwarder adding the option crcSalt = <SOURCE> to inputs.conf;
  • restart Forwarder;
  • after the logs are reindexed delete the crcSalt = <SOURCE> row from inputs.conf and restart Forwarder.

In this way logs are reindexed and sent to the new index.

Remember that if you add the can_delete role to you admin user, it's a good idea disable this feature as soon as after the deletion, it isn't a good idea to have this feature enabled.

Bye.
Giuseppe

View solution in original post

tanglong
Engager

Thanks for all comment, its helpful with me. Very important keyword.

  1. Its show on Indexer.

alt text

  1. This is config inputs.conf and "weblog" sourcetype not show in Splunk main page.

alt text

Anyway to help me? Thanks so much!

0 Karma

woodcock
Esteemed Legend

The fishbucket on the forwarder will remember that this file has already been forwarded and will refuse to forward it again. You can either:
1: Clear the fishbucket for this file.
2: Manually send the file using splunk add oneshot.
Also, do not use the CLI to configure ANYTHING in Splunk. You should create your own forwarder app and put your configurations in that.

0 Karma

gcusello
SplunkTrust
SplunkTrust

Hi tanglong,
when you already ingested logs from a file you cannot ingest them again, also renaming the file.
To do this you have to use a workaround:

  • delete the old logs from the main index using the delete command, remember that only special users (can_delete role) can delete logs, this step isn't mandatory;
  • create the new index weblog on Indexer
  • modify inputs.conf on Forwarder adding the option index = weblog to inputs.conf;
  • modify inputs.conf on Forwarder adding the option crcSalt = <SOURCE> to inputs.conf;
  • restart Forwarder;
  • after the logs are reindexed delete the crcSalt = <SOURCE> row from inputs.conf and restart Forwarder.

In this way logs are reindexed and sent to the new index.

Remember that if you add the can_delete role to you admin user, it's a good idea disable this feature as soon as after the deletion, it isn't a good idea to have this feature enabled.

Bye.
Giuseppe

DavidHourani
Super Champion

Are you trying to re-ingest the same data ?

0 Karma
Get Updates on the Splunk Community!

Get ready to show some Splunk Certification swagger at .conf24!

Dive into the deep end of data by earning a Splunk Certification at .conf24. We're enticing you again this ...

Built-in Service Level Objectives Management to Bridge the Gap Between Service & ...

Now On-Demand Join us to learn more about how you can leverage Service Level Objectives (SLOs) and the new ...

Database Performance Sidebar Panel Now on APM Database Query Performance & Service ...

We’ve streamlined the troubleshooting experience for database-related service issues by adding a database ...