Developing for Splunk Enterprise

SimpleXML dashboard version=1.1 backwards compatibility

helge
Builder

I read the documentation on the mandatory SimpleXML dashboard tag version=1.1 which is required by Splunk Enterprise 8.2 and Splunk Cloud.

According to the Simple XML reference, Splunk Enterprise 8.1.x gives a warning when it sees the 1.1 version tag:

Splunk Enterprise version 8.1.x and lower do not recognize this attribute and give a warning.

My question is:

How can I create an app that works on all currently supported versions of Splunk Enterprise and Cloud without errors or warnings?

Labels (1)
1 Solution

helge
Builder

Splunk giving a warning seems to be an error in the documentation. In my testing with Splunk 8.1.5, I did not notice any warnings after adding version="1.1", neither in the UI nor in Splunk's log files.

View solution in original post

0 Karma

helge
Builder

Splunk giving a warning seems to be an error in the documentation. In my testing with Splunk 8.1.5, I did not notice any warnings after adding version="1.1", neither in the UI nor in Splunk's log files.

0 Karma