Developing for Splunk Enterprise
Highlighted

Is Splunk SDK for Python compatible with python 3.7 (upgrading a server from 3.3.5 to 3.7.2)?

Explorer

We are thinking about upgrading python on one of our servers from 3.3.5 to 3.7.2
We have some scripts that use the Splunk SDK for Python running on the server, so I am wondering if anyone has tested the SDK with python 3.7 or is currently using it.
Per the documentation though "The Splunk SDK for Python supports Python versions 2.7 or later. The Splunk SDK for Python has been tested with Python v2.7 and v3.5."

Any advice, please.

Thank you in advance.

Labels (1)