Developing for Splunk Enterprise

Is Kotlin Required for the latest MINT Android plugin?

New Member

I'm getting an error when trying to use the MINT instrumentation via the Mint gradle plugin. com.splunk.mint.gradle.android.plugin. Is the Kotlin plugin required to use the latest plugin for Mint (5.2.2)?

"Error:Could not find org.jetbrains.kotlin:kotlin-stdlib-jre8:1.1.1."

0 Karma

New Member

Definitely looks like something introduced in the 5.2.x versions of the plugin. Dependencies on the org.jetbrains.kotlin:kotlin-stdli, org.jetbrains.kotlin:kotlin-test-junit, & org.jetbrains.kotlin:kotlin-stdlib-jre8 don't appear in the 5.1.0 version of the plugin. If Kotlin is required it needs to be documented in the installation instructions. Also, since Kotlin isn't officially supported by Android Studio until version 3.x, and version 3.x is still in canary. Is this requirement a little premature?

0 Karma
State of Splunk Careers

Access the Splunk Careers Report to see real data that shows how Splunk mastery increases your value and job satisfaction.

Find out what your skills are worth!