Developing for Splunk Enterprise

How come enable boot start doesn't work with Splunk on SUSE Enterprise 15?

asabatini85
Path Finder

Hi guys,

I installed Splunk on Enterprise SUSE enterprise 15.

When I run the command splunk enable boot-start, I received this error:

/sbin/insserv: No such file or directory

someone can help me?

Tags (1)
0 Karma
1 Solution

asabatini85
Path Finder

I fixed the issue

Suse Enterprise 15 need this package to run service at boot time.

insserv-compat

  • STEP 1 install the package

zypper install insserv-compat

  • STEP 2 run enable comand

./splunk enable boot-start

  • STEP 3 set the run level

chkconfig --set splunk on

View solution in original post

asabatini85
Path Finder

I fixed the issue

Suse Enterprise 15 need this package to run service at boot time.

insserv-compat

  • STEP 1 install the package

zypper install insserv-compat

  • STEP 2 run enable comand

./splunk enable boot-start

  • STEP 3 set the run level

chkconfig --set splunk on

View solution in original post

joebisesi
Path Finder

Are you running this command from the location of the Splunk/bin directory? If you don't have the homepath for splunk configured in your .bash_profile, you would need to run a command similar to this: /"directory where splunk is installed"/bin/splunk enable boot-start

If you don't want to type the full path or cd to that directory, you need to set the homepath similar to this in your .bash_profile:

export SPLUNK_HOME='the directory where splunk is installed'
export PATH ='the directory where the splunk/bin dir is':$PATH

I believe this is a rebootable offense, or at least you have to log out and back in for it to take.

Hope this helps

0 Karma

asabatini85
Path Finder

thanks, but I fixed the issue by myself

0 Karma
Register for .conf21 Now! Go Vegas or Go Virtual!

How will you .conf21? You decide! Go in-person in Las Vegas, 10/18-10/21, or go online with .conf21 Virtual, 10/19-10/20.