Developing for Splunk Enterprise

Do apps built using Add-On Builder require changes for JQuery 3.5?

gf13579
Communicator

Splunk have advised that they're deprecating older versions of JQuery: Make Your App More Secure By Updating to jQuery® Version 3.5 or Newer | Splunk.

Are add-ons built using Add-On Builder impacted? I can see various references to jquery within the AOB-generated appserver\static\ content (common.js, configuration_page.js...) but I have no idea whether there's going to be any impact on my simple modular input apps built using AOB.

Posting here as figured many other people would have a similar question.

Labels (2)
Tags (2)
0 Karma
1 Solution

gf13579
Communicator

Answering my own question using the email sent in late July:

Splunk recently released Add-on Builder v4.0.0 . If you built your Splunkbase solution with a prior release of Add-on Builder, please update your app(s) as soon as possible, and no later than August 31, 2021, using this latest version so that your Splunkbase app(s) will be compatible with the next major releases of Splunk Cloud Platform and Splunk Enterprise.

As we move to newer versions of Python and jQuery in the platform, we have updated Add-on Builder to support them. That means that the current release of your application(s) based on the prior Add-on Builder release will not be compatible with the new Splunk releases coming later this year.

You can find more information about this latest Add-On Builder release in the Splunk Add-on Builder Use Guide . To update your add-on, you will need to export your current project, then import it into this new Add-on Builder release. You can find more information in the “Import and export an add-on project ” section of the user guide.

View solution in original post

0 Karma

gf13579
Communicator

Answering my own question using the email sent in late July:

Splunk recently released Add-on Builder v4.0.0 . If you built your Splunkbase solution with a prior release of Add-on Builder, please update your app(s) as soon as possible, and no later than August 31, 2021, using this latest version so that your Splunkbase app(s) will be compatible with the next major releases of Splunk Cloud Platform and Splunk Enterprise.

As we move to newer versions of Python and jQuery in the platform, we have updated Add-on Builder to support them. That means that the current release of your application(s) based on the prior Add-on Builder release will not be compatible with the new Splunk releases coming later this year.

You can find more information about this latest Add-On Builder release in the Splunk Add-on Builder Use Guide . To update your add-on, you will need to export your current project, then import it into this new Add-on Builder release. You can find more information in the “Import and export an add-on project ” section of the user guide.

View solution in original post

0 Karma
Did you miss .conf21 Virtual?

Good news! The event's keynotes and many of its breakout sessions are now available online, and still totally FREE!