Deployment Architecture

Trying to change licensing master <> slave

pil321
Communicator

I'm trying to change the license master association. I want my current master to become the slave, and vice versa. There are no clusters set up...just two Splunk indexers on the same license pool. When I try to do this from the WebUI on the current master, I'm getting this error message:

Signature mismatch between license slave=splunk-master-server and this license master. Please make sure that the pass4SymmKey setting in server.conf, under [general], is the same for the license master and all its slaves...

I don't ever remember setting this password...so I started doing some searching and I found this.

When I reset the pass4SymmKey passwords on both servers, I still get the same error message.

Any ideas?

0 Karma
1 Solution

adonio
Ultra Champion

try first to go to the instance that is the slave, navigate to settings -> licensing -> click change to master on top. or change license group and set as its own master.
add the license key file and set the slave as master.
restart splunk
now you will receive a message that 2 masters use the same key.
go the the old master, settings -> licensing -> click change to slave -> add new master details and mgmt port -> restart
all done
hope it helps

View solution in original post

0 Karma

adonio
Ultra Champion

try first to go to the instance that is the slave, navigate to settings -> licensing -> click change to master on top. or change license group and set as its own master.
add the license key file and set the slave as master.
restart splunk
now you will receive a message that 2 masters use the same key.
go the the old master, settings -> licensing -> click change to slave -> add new master details and mgmt port -> restart
all done
hope it helps

0 Karma

pil321
Communicator

That did it...

Thank you adino!

0 Karma

regriffith
Path Finder

I ran into the same problem and didn't know what the password was in the pass4SymmKey setting in server.conf. I tried a few things in other posts and nothing worked. I noticed that the default server.conf uses changeme as the password. I entered this as the password in the local server.conf, added the master license path to master_uri and restarted. Error is now gone.

0 Karma
Get Updates on the Splunk Community!

2024 Splunk Career Impact Survey | Earn a $20 gift card for participating!

Hear ye, hear ye! The time has come again for Splunk's annual Career Impact Survey!  We need your help by ...

Optimize Cloud Monitoring

  TECH TALKS Optimize Cloud Monitoring Tuesday, August 13, 2024  |  11:00AM–12:00PM PST   Register to ...

What's New in Splunk Cloud Platform 9.2.2403?

Hi Splunky people! We are excited to share the newest updates in Splunk Cloud Platform 9.2.2403! Analysts can ...