Deployment Architecture

Query on Deployment Server App Deployment

Path Finder

Hi All,

I have a deployment Server with 2 indexers and 1 search head.

I have developed an app which needs to be deployed to all these servers.

The app which i developed , should be in disabled state by default and hence in the default's folder "app.conf" i did the following

[install]
state = disabled

Couple of things i noticed in deployment:

1) When i restart my deployment server , automatically a file app.conf loads into the local folder.
2) When the app is deployed into the search head and indexers , the app is by default in Enabled state.

How to over come this issue ? So when i install the app, as i have defined , it should be in disabled state itself.

0 Karma
1 Solution

Path Finder

Hi All,

I sorted out this issue myself.

in the serverclass.conf file , there is an option which is enabled by default
StateOnClient = enabled.

For the app which i have created i added the following:

[serverClass::app:]
stateOnClient = disabled

View solution in original post

Path Finder

Hi All,

I sorted out this issue myself.

in the serverclass.conf file , there is an option which is enabled by default
StateOnClient = enabled.

For the app which i have created i added the following:

[serverClass::app:]
stateOnClient = disabled

View solution in original post

Champion

Mark it as answer please

0 Karma

Path Finder

Hi,

I do not have the local folder itself in my app itself.

I have just the default's folder app.conf and set as state = disabled.

When i restart the deployment server , the local -->app.conf gets autogenerated.

Or even without restarting , if i just run the command "splunk reload deploy-server" the app.conf gets generated inside the local folder.

0 Karma

SplunkTrust
SplunkTrust

Just to ensure, you've followed these steps
1.You created the yourapp in the deployment-server\etc\apps.
2. You disabled the app in etc/yourapp/default/app.conf. If there is etc/yourapp/local/app.conf present, same change is done there.
3. You copied this etc/apps/yourapp into etc/deployment-apps folder (with app.conf in both local and default (if present) state=disabled)
4. You restarted deployment server.

0 Karma