Deployment Architecture

How can I determine where socket timeout is coming from when I peer indexer to search head?

New Member

I am trying to solve an issue with some search heads that have had issues accepting a set of indexers. I am trying to add in indexers that have been networked to a new set of search heads. When I try to add them in, I get the response Socket error communicating with splunkd (error=timed out), path = /servicesNS/admin/search/search/distributed/peers. I have tried looking around for this error message but I cant find anything that is quite like the situation I am seeing.

What I have tried thus far:
- Update sendTimeout in distsearch.conf on the search head to 60 seconds and restart splunk. The change took but the indexers still appeared down to the new search head
- I have also noticed a splunkdtimeout in the web.conf setting file but I am not sure if that is a red herring.
- I am also interested if it could be the indexer itself despite the indexer working for other servers.

0 Karma
.conf21 Now Fully Virtual!
Register for FREE Today!

We've made .conf21 totally virtual and totally FREE! Our completely online experience will run from 10/19 through 10/20 with some additional events, too!