Deployment Architecture

Error while linking app to Splunk directory on Putty

POR160893
Builder

Hi,

I am creating a React app for Splunk on a Putty terminal. I am following the following tutorial:
https://splunkui.splunk.com/Create/AppTutorial

However, I am unable to build the output directory needed to be symlinked into Splunk's application directory with the command: 
yarn run link:app

I have set the $SPLUNK_HOME environmental variable to /opt/splunk but everytime I run the yarn run link:app command, I keep getting the following error:

node: error while loading shared libraries: libcrypto.so.1.0.0: cannot open shared object file: No such file or directory


How can this be solved please? 


Thanks,

Labels (1)
0 Karma
Get Updates on the Splunk Community!

What’s new on Splunk Lantern in August

This month’s Splunk Lantern update gives you the low-down on all of the articles we’ve published over the past ...

Welcome to the Future of Data Search & Exploration

You have more data coming at you than ever before. Over the next five years, the total amount of digital data ...

This Week's Community Digest - Splunk Community Happenings [8.3.22]

Get the latest news and updates from the Splunk Community here! News From Splunk Answers ✍️ Splunk Answers is ...