Deployment Architecture

Error while linking app to Splunk directory on Putty

POR160893
Contributor

Hi,

I am creating a React app for Splunk on a Putty terminal. I am following the following tutorial:
https://splunkui.splunk.com/Create/AppTutorial

However, I am unable to build the output directory needed to be symlinked into Splunk's application directory with the command: 
yarn run link:app

I have set the $SPLUNK_HOME environmental variable to /opt/splunk but everytime I run the yarn run link:app command, I keep getting the following error:

node: error while loading shared libraries: libcrypto.so.1.0.0: cannot open shared object file: No such file or directory


How can this be solved please? 


Thanks,

Labels (1)
0 Karma
Get Updates on the Splunk Community!

Maximize the Value from Microsoft Defender with Splunk

 Watch NowJoin Splunk and Sens Consulting for this Security Edition Tech TalkWho should attend:  Security ...

This Week's Community Digest - Splunk Community Happenings [6.27.22]

Get the latest news and updates from the Splunk Community here! News From Splunk Answers ✍️ Splunk Answers is ...

Reminder! Splunk Love Promo: $25 Visa Gift Card for Your Honest SOAR Review With ...

We recently launched our first Splunk Love Special, and it's gone phenomenally well, so we're doing it again, ...