Deployment Architecture
Highlighted

Disable Phonehome to Deployment Server

Contributor

We installed the forwarders looking for a deployment server and typed in the splunk server hostname. We actually did not want this and I"m not sure why we even did this. Anyways we would like to disable the phone home bit from each client with an installed forwarder, where/how do I go about doing this? I imagine it's a one-line change.

Thanks!

Tags (1)
0 Karma
Highlighted

Re: Disable Phonehome to Deployment Server

Path Finder

disabled = True

In the deploymentclient.conf file on the fowarder should stop it from connecting.

0 Karma
Highlighted

Re: Disable Phonehome to Deployment Server

Path Finder
0 Karma
Highlighted

Re: Disable Phonehome to Deployment Server

Contributor

Thanks for responding, however we cannot find the filename "deploymentclient.conf" What's the path to the file?

Thanks!

0 Karma
Highlighted

Re: Disable Phonehome to Deployment Server

Path Finder

Create a deploymentclient.conf in the $SPLUNK_HOME/etc/system/local/ on that Splunk forwarder instance with the following content and restart the forwarder:

[deployment-client]
disabled = true

0 Karma
Highlighted

Re: Disable Phonehome to Deployment Server

Splunk Employee
Splunk Employee

Note that you could probably safely remove the deploymentclient.conf if you don't want any of this functionality. The installer (on Windows) creates this file from scratch with data you provide during the install wizard.

0 Karma