Deployment Architecture

Cannot launch React app on Splunk

POR160893
Builder

Hi,

I have created a React app and symlinked it to Splunk. It now appears as one of the installed apps but I am given no option to launch the app.

POR160893_0-1653294621304.png



What can I do?

Thanks

Labels (1)
0 Karma

ITWhisperer
SplunkTrust
SplunkTrust

You can only launch and app if it is visible, yours is not

ITWhisperer_0-1653296722142.png

 

POR160893
Builder

How can I make it visible?

0 Karma

ITWhisperer
SplunkTrust
SplunkTrust

Try Edit Properties / Visible / Yes

0 Karma

POR160893
Builder

Ok, this worked thanks!

However, once the app is visible, it appears like this:

POR160893_0-1653297790988.png

However, it should look like the following:

 

POR160893_2-1653297846748.png

 

 






0 Karma

ITWhisperer
SplunkTrust
SplunkTrust

You need to change the default nav settings for your app

ITWhisperer_0-1653299341628.png

Make sure you select the right app from the dropdown list
ITWhisperer_1-1653299376092.png

Edit XML accordingly

ITWhisperer_2-1653299464765.png

 

0 Karma

POR160893
Builder

Do not see any Nav option sadly:

POR160893_0-1653302064866.png

 

0 Karma

ITWhisperer
SplunkTrust
SplunkTrust

set the filter to "default"

0 Karma

POR160893
Builder

I started a 2nd time to create a 2nd React app but I still get the following:

POR160893_0-1653308349555.png



And if I hard-coded the symlink, the configurations will not be correct like the first app.

 

0 Karma
Get Updates on the Splunk Community!

Ready, Set, SOAR: How Utility Apps Can Up Level Your Playbooks!

 WATCH NOW Powering your capabilities has never been so easy with ready-made Splunk® SOAR Utility Apps. Parse ...

DevSecOps: Why You Should Care and How To Get Started

 WATCH NOW In this Tech Talk we will talk about what people mean by DevSecOps and deep dive into the different ...

Introducing Ingest Actions: Filter, Mask, Route, Repeat

WATCH NOW Ingest Actions (IA) is the best new way to easily filter, mask and route your data in Splunk® ...