Dashboards & Visualizations

indexes not appear in cluster dashboard

crazyeva
Contributor

i have added "repFactor=auto" to each peer's indexes.conf and "rolling-restarted" them all
i have put into them some data which can be seen on searchhead
but they are still not there

1 Solution

adrianathome
Communicator

The indexes will not show up until they receive some data. Are you sending data to the indexes?

View solution in original post

crazyeva
Contributor

after i "splunk restarted" them all, twice.
they showed up....

0 Karma

adrianathome
Communicator

The indexes will not show up until they receive some data. Are you sending data to the indexes?

View solution in original post

crazyeva
Contributor

|metadata type=sourcetypes index=idx-dn:
firstTime lastTime recentTime sourcetype totalCount type
1 1336071194 1342402517 1371955561 DNlog 1079499 sourcetypes

there are events in that index

0 Karma

adrianathome
Communicator

You said that you are receiving events. Look at the events in your search head and verify the index of the events.

0 Karma

crazyeva
Contributor

sorry i dont quite understand you. the index name is "idx-dn"

0 Karma

adrianathome
Communicator

What is the index of the events that you are receiving?

0 Karma

crazyeva
Contributor

inputs.conf and outputs.conf on FORWARDER:
[monitor:///DATA/DNlog/DN.log.*]
sourcetype = DNlog
index = IDX-DN
host = LogDB
disabled = false

[tcpout]
defaultGroup = Peer_Group
maxQueueSize = 500MB
[tcpout:Peer_Group]
autoLB = true
autoLBFrequency = 1
useACK = true
server = 172.16.40.98:9997, 172.16.40.99:9997, ......

indexes.conf on PEER-NODEs:
[IDX-DN]
repFactor = auto
coldPath = $SPLUNK_DB/idx-dn/colddb
homePath = $SPLUNK_DB/idx-dn/db
maxDataSize = auto_high_volume
thawedPath = $SPLUNK_DB/idx-dn/thaweddb

0 Karma

adrianathome
Communicator

What is the value of index for the events that you are receiving? Could it be the default index? If so, you need to specify the index in the inputs.cont of your forwarder.

0 Karma

crazyeva
Contributor

yes, i did,i can see data on searchhead

0 Karma
.conf21 Now Fully Virtual!
Register for FREE Today!

We've made .conf21 totally virtual and totally FREE! Our completely online experience will run from 10/19 through 10/20 with some additional events, too!