Dashboards & Visualizations

/debug/refresh does not work anymore on 6.3.0 on version with Free license group

lakromani
Builder

As of 6.3.0 I am not able to run http://your-server/en-US/debug/refresh when it on Free license group

On Free license group server, there is no login, no group or role setting, just autologin with the admin user.
So there are no way to give the role with the web_debug
On 6.2.5 this works fine.

As it is now, only way to reload files as I see, is to restart the server service.
Is this a bug in 6.3.0?


Update 12.10.2017
Does not work on Splunk 7.0 either.

Getting following error:

<response>
  <messages>
    <msg type="ERROR">Forbidden</msg>
  </messages>
</response>

Also tested adding to web.conf, but did not help
enableWebDebug = true

PS it works if you using a free developer license.

0 Karma

arimaldo
Explorer

Even with a paid license you will see this error and I agree with the comment from "andreworg" (Oct 12, 2017) this is a bug.

0 Karma

rafamss
Contributor

Hey @lakromani,

I use the command like you put above. The only different thing of your command is put the port your Splunk, like this: http://localhost:8000/en-US/debug/refresh. I always use this command every time that I need in my local and remote Splunk with different versions of Splunk and it's works fine.

0 Karma

lakromani
Builder

Port has nothing to do with it.
It seems that Splunk has removed it from the Free license group.
So if you have a payed version, it will work.

0 Karma

lguinn2
Legend

I don't think this is a known bug. On free Splunk, just restart Splunk to have it apply your configuration file changes. This always works.

0 Karma

andreworg
Engager

Well, IMHO it should be marked as a bug. It shouldn't be necessary to restart the daemon. The default user when using the free license should have the web_debug role enabled. If you don't want to enable the feature, you still have the option of disabling it via the enableWebDebug switch in web.conf.

0 Karma

lakromani
Builder

Then someone did change this from 6.2.5 to 6.3.0
Why on earth change this behavior?????
You do not always have access to the physical server.
If some one at Splunk design read this, please add this function back to the Splunk with Free license.

0 Karma

MuS
SplunkTrust
SplunkTrust

This feature is still available in free; but I just discovered that it now requires you the press a button to do it 😞
btw it's the same if you use a enterprise license and no docs found so far...

lakromani
Builder

Thanks.

You find it here:

Settings -> Server controls -> Restart Splunk
0 Karma
Take the 2021 Splunk Career Survey

Help us learn about how Splunk has
impacted your career by taking the 2021 Splunk Career Survey.

Earn $50 in Amazon cash!