Dashboards & Visualizations

XML help - collection isn't showing up in this navigation

ddrillic
Ultra Champion

We have the following code -

<nav search_view="search" color="#65A637">
  <view name="search" default='true' />
  <view name="data_models" />
  <view name="reports" />
  <view name="alerts" />
  <collection label="AlertsCategory">
   <view name="FailureAlerts" />
   <view name="HTTPStatusAlerts" /> 
  </collection>
  <view name="failure" /> 
  <view name="dashboards" />
    <collection label="DrilldownList" >
      <collection label="Domains" > 
     <view name="xxxxxx" />
        <view name="aaaa" />
        <view name="bbbb" />
      </collection>
      <collection label="Domain-Stats-List" > 
       <view name="domain_dashboard" />
        <view name="user_domain_stats_dashboard" />
     </collection>
  </collection>
</nav>

For some reason the following doesn't show up -

      <collection label="AlertsCategory">
       <view name="FailureAlerts" />
       <view name="HTTPStatusAlerts" /> 
      </collection>

What can it be?

0 Karma
1 Solution

niketnilay
Legend

@ddrillic, Make sure of the following from Settings > User interface > Views

1) The View Names FailureAlerts and HTTPStatusAlerts exist
2) The View Name casing is the same
3) The permissions on the above views are correct for logged in user.
If any of the above is not as expected Views might not show in collection.

PS: You can try the following two to test as well:
Test 1) Just retain the view names which are not showing up and remove their collection node to see whether the view show up. If they do not, either the view does not exist or logged in user does not have the right permission to the view.

<view name="FailureAlerts" />
<view name="HTTPStatusAlerts" /> 

Test 2) Try to open the view through logged in user by passing the the view name. If they do not, either the view does not exist or logged in user does not have the right permission to the view.

http://<YourSplunkServer>/en-US/app/<YourAppName>/FailureAlerts
http://<YourSplunkServer>/en-US/app/<YourAppName>/HTTPStatusAlerts
____________________________________________
| makeresults | eval message= "Happy Splunking!!!"

View solution in original post

0 Karma

niketnilay
Legend

@ddrillic, Make sure of the following from Settings > User interface > Views

1) The View Names FailureAlerts and HTTPStatusAlerts exist
2) The View Name casing is the same
3) The permissions on the above views are correct for logged in user.
If any of the above is not as expected Views might not show in collection.

PS: You can try the following two to test as well:
Test 1) Just retain the view names which are not showing up and remove their collection node to see whether the view show up. If they do not, either the view does not exist or logged in user does not have the right permission to the view.

<view name="FailureAlerts" />
<view name="HTTPStatusAlerts" /> 

Test 2) Try to open the view through logged in user by passing the the view name. If they do not, either the view does not exist or logged in user does not have the right permission to the view.

http://<YourSplunkServer>/en-US/app/<YourAppName>/FailureAlerts
http://<YourSplunkServer>/en-US/app/<YourAppName>/HTTPStatusAlerts
____________________________________________
| makeresults | eval message= "Happy Splunking!!!"

View solution in original post

0 Karma

ddrillic
Ultra Champion

Perfect!!!! very kind. Please convert to an answer.

0 Karma

niketnilay
Legend

Glad it worked! I have converted to answer.

____________________________________________
| makeresults | eval message= "Happy Splunking!!!"
0 Karma
Did you miss .conf21 Virtual?

Good news! The event's keynotes and many of its breakout sessions are now available online, and still totally FREE!