Dashboards & Visualizations

Why is a Splunk embedded dashboard failing with search head clustering?

Builder

I tried embedding a dashboard and using the iFrame in an html page. The page loads, but the dashboard fails to load. In the console I can see the error -

{"messages":[{"type":"FATAL","text":"String not found in literals.conf: Failed to locate job status for job=scheduler__dinesh_YmFjX3NwbHVua19ob21l__RMD5779c822ff0e74d9b_at_1433851800_90796_F8A25EBE-C264-45EE-A0A6-9E1BE01CF073"}]}

The same dashboard works if embedded correctly in the non search head clustering environment, but fails when embedding from a search head cluster member.

Tried this - http://docs.splunk.com/Documentation/Splunk/6.2.3/Admin/Serverconf#embedSecret
without any luck.

Anyone has an idea how to fix this?

1 Solution

Splunk Employee
Splunk Employee

Hello: While I understand the perspective that it should be fixed in a minor release, I am happy to note that it IS fixed in 6.3.x which is out. Moreover, 6.3.1 comes out today/tomorrow (before Nov 5th depending on where you live) and that has many bug fixes including this one.

Hope that helps!

View solution in original post

0 Karma

Splunk Employee
Splunk Employee

Hello: While I understand the perspective that it should be fixed in a minor release, I am happy to note that it IS fixed in 6.3.x which is out. Moreover, 6.3.1 comes out today/tomorrow (before Nov 5th depending on where you live) and that has many bug fixes including this one.

Hope that helps!

View solution in original post

0 Karma

Communicator

Where can I find documentation on embedding a dashboard (not a report)? Or was this post referring to reports the entire time and embedded dashboards is still not supported?

0 Karma

Splunk Employee
Splunk Employee

Hi,

Currently this a limitation when migrating to SHC and we are working on fixing this in our next major release of Splunk. For reference this issue is related to SPL-96384.

Thanks,

0 Karma

Motivator

Thanks, but isn't this exactly what embedSecret is for, thus making this a bug that should be fixed in a minor release instead of having to wait for the next major release?

Explorer

We are seeing same issue with our sh cluster. Embed URL is working on the box where URL is generated but across the cluster. We tried setting embedSecret in server.conf with no success.

0 Karma

Explorer

We are currently experiencing the exact same issues with embedded reports. embedSecret is set for the search head cluster.

0 Karma

Engager

Has anyone found a solution to this? I am seeing the same issue in our environment with a clustered search head

0 Karma