Dashboards & Visualizations

Putting a custom logo on the login screen

Builder

I'm trying to customize our Splunk installation to remove all links to and mentions of splunk.com (this is a part of our OEM agreement). I managed to "neutralize" the login screen using the suggestion from this great comment in the docs (look for the comment by Kbains of January 12, 2015):
http://docs.splunk.com/Documentation/Splunk/latest/AdvancedDev/CustomizeLogin

However, the background image example isn't working - and I have a feeling I know why: at login time, you are not yet logged in (duh!), and the access to the application resources is granted only to the users with read permission. Not being a user yet, one cannot load the image.

What is the "public" folder for Splunk images and the external URL pointing there?

1 Solution

Builder

I figured it out. The folder you specify in web.conf as static_dir ( share/splunk/search_mrsparkle/exposed by default) is referred from within Splunk screens as /static. What I did was put our company's logo in img/skins/default under it and refer to it from login_content as background: url(/static/img/skins/default/ourCompanyLogo250x250.png) no-repeat.

View solution in original post

Path Finder

I'm running into an issue where I accidentally didn't drop the png file into the /opt/splunk/etc/app/search/appserver/static/logincustomlogo/ folder and got a broken image link. I dropped the file and restarted splunk but still getting the broken link. Has anyone else ran into this issue?

Thanks,

0 Karma

Splunk Employee
Splunk Employee

Hi from the future! In 6.5+ this is easy. Settings > System > Server Settings > Login Background.

http://docs.splunk.com/Documentation/Splunk/6.6.1/AdvancedDev/CustomizeLogin

Contributor

Hi,

Here is what I inserted for my company (after having put the logo image file in share/splunk/search_mrsparkle/exposed/img/skins/default):

configuration of web.conf in etc/system/local:

[settings]
updateCheckerBaseURL = 0
logincontent = htmlcode to point to that image file: img src="/static/img/skins/default/my_logo.png and insert simple text as a presentation for the company...

Skender Kollcaku

Builder

I figured it out. The folder you specify in web.conf as static_dir ( share/splunk/search_mrsparkle/exposed by default) is referred from within Splunk screens as /static. What I did was put our company's logo in img/skins/default under it and refer to it from login_content as background: url(/static/img/skins/default/ourCompanyLogo250x250.png) no-repeat.

View solution in original post

Path Finder

I am having trouble with this... I have tried the following:
login_content = {background: url(/static/img/skins/default/company_logo.png) no-repeat;}
login_content = background: url(/static/img/skins/default/company_logo.png) no-repeat

and neither works. All I get is the text above on the splunk login screen. What am i doing wrong exactly?

0 Karma

Builder

You need to use

login_content = <style> background: url(/static/...); </style>

for it to work. The example by KBains I was referring to is no longer in the "latest" documentation, so here is a more permanent link:
link text

0 Karma

Communicator

Hi @arkadyz, Thanks for response but this didn't help. The client's custom logo is not coming up on the login page with :

login_content =

any other solution.. ?

0 Karma

Communicator

Hi @charliedgz,
Even i am facing the same problem in Splunk 6.4.

in addition to above, i tried login_content=img src="/static/img/skins/default/company_logo.png""
but no luck.
I have also gone to share/splunk/search_mrsparkle/exposed/css/skins/default/default.css
and under .appLogo , updated my_client's_logo_name.png
but that also didnt work after splunk service restart.

May be @arkadyz1 , @skender27 or @ppablo can help ?
Thanks in advance

0 Karma