Dashboards & Visualizations

Port Scan Dashboard

tonythomas42
New Member

I want a dashboard to be created for port scan(to detect 2000 port scan attempts from one single IP towards single destination within 5 min)
I tried creating one dashboard but the values in the dashboard keep on changing every time the dashboard refreshes. I want a dashboard that will display all the port scan attempts for last 24 hrs satisfying the condition (2000 port scan attempts in 5 min) and the values in the dashboard should stay till 24 hrs.

Tags (1)
0 Karma

sumanssah
Communicator

try using below-mentioned search for "port scan to single IP multiple ports"

| tstats `summariesonly`   dc(All_Traffic.dest_port) as dc_dest_port  values(All_Traffic.dest_zone) as dest_zone min(All_Traffic.dest_port) as min_port max(All_Traffic.dest_port as max_port values(All_Traffic.action) as action  from datamodel=Network_Traffic.All_Traffic where NOT (All_Traffic.dest_port=443 OR  All_Traffic.dest_port=80 )  by All_Traffic.src_ip All_Traffic.dest_ip _time span=5m
| `drop_dm_object_name(All_Traffic)`  
| where dc_dest_port>2000  
| eval ip_range=min_port."-".max_port
0 Karma

to4kawa
Ultra Champion

Which do you want to do?
Create something: good luck. you only know your logs.
Find Apps: splunk security essentials

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Splunk Add-on for Microsoft Windows 11.0.3: Parse Once, Search Faster

The updated Splunk Add-on for Microsoft Windows helps customers search Windows events faster by reducing ...

What's New in Splunk Enterprise Security 8.8 and Beyond

Threats move at machine speed. Keeping up should not depend on having the biggest budget, the largest team, or ...

A Four-Part Event Series: State of Observability - Where AI Meets Performance

As AI agents take on more complex tasks, teams need greater visibility into how they behave, what they cost, ...