Dashboards & Visualizations

How to remove the View Dashboard link from PDF report emails?



I have scheduled PDF delivery of my reports.

I see a hyperlink - View dashboard - appearing in the email body. How do I remove this? I tried all the options in alert_actions.conf file under the [email] stanza. The link appears always.


Path Finder

I updated the action.email.include.results_link = 0 & action.email.include.view_link
= 0 in Advance Edit for the schedule view from Setting - Searches/Reports & Views and now the schedule dashboard doesnt show the "View dashboard" link


Thank you !!!

Tags (1)
0 Karma


If you open Reports in the UI and Edit Schedule on the report involved, perhaps you have actual text and a link in the message body? You can uncheck all of the items in there and test to see if that fixes it.

The setting you are looking for should be message.alert = inside alert_actions.conf. It is set up in etc/system/local/alert_actions.conf, each setting in there overriding a setting in the etc/system/default/alert_actions.conf (which you shouldn't edit). So if you were looking at the local version, I don't think it'll have that setting in there unless it's already been overridden.

Let us know if either of these work!

Get Updates on the Splunk Community!

Enterprise Security Content Update (ESCU) | New Releases

In the last month, the Splunk Threat Research Team (STRT) has had 2 releases of new security content via the ...

Announcing the 1st Round Champion’s Tribute Winners of the Great Resilience Quest

We are happy to announce the 20 lucky questers who are selected to be the first round of Champion's Tribute ...

We’ve Got Education Validation!

Are you feeling it? All the career-boosting benefits of up-skilling with Splunk? It’s not just a feeling, it's ...