Dashboards & Visualizations

How to change the default PDF timeout of 60 minutes for a scheduled PDF delivery of a dashboard?

Contributor

Hi,
I have a dashboard that I'm trying to schedule a PDF delivery of. However, the search takes a little over an hour to complete and according to the inspect log, the pdf generation stops at 60 minutes. Can this be changed?

By default when a schedule is created the default is:

$SPLUNK_HOME/etc/users/admin/search/local/savedsearches.conf
[ScheduledView_test]
action.email.maxtime = 60m

I've tried setting the following with no effect:

$SPLUNK_HOME/etc/system/local/limits.conf
[pdf]
render_endpoint_timeout = 7200

$SPLUNK_HOME/etc/apps/search/bin/sendemail.py
PDFGEN_SIMPLE_REQUEST_TIMEOUT = 7200

$SPLUNK_HOME/etc/system/bin/pdfgen_endpoint.py
DEFAULT_TIMEOUT = 7200

$SPLUNK_HOME/etc/system/local/alert_actions.conf
[email]
maxtime = 120m

There is no option in the GUI from what I can see to enable a user to change it for their schedule, so I need to set this globally as having to edit a users savedsearches.conf every time a schedule is created is stupid.

Thanks in advance.

Splunk Employee
Splunk Employee

limits.conf

[scheduler]
scheduled_view_timeout = <int>[s|m|h|d]
 * The maximum amount of time that a scheduled view (pdf delivery) would be allowed to render
 * Defaults to 60m

http://docs.splunk.com/Documentation/Splunk/6.1/Admin/Limitsconf

Communicator

6.3 allow to set action.email.maxtime (in advanced edit) for any scheduled pdf.

but there does not seem to be a field for changing:
$SPLUNK_HOME/etc/apps/search/bin/sendemail.py
PDFGEN_SIMPLE_REQUEST_TIMEOUT = 3600
$SPLUNK_HOME/etc/system/bin/pdfgen_endpoint.py
DEFAULT_TIMEOUT = 3600 # in seconds

and patching the code does not strike me as a good idea.

0 Karma

Contributor

What I did notice though, is that if I login as admin the change in sendmail.py works. As a normal user (even with admin rights) it does not.

0 Karma

Contributor

I have raised this as case 212575

0 Karma