Dashboards & Visualizations

Drop Down is not highlighting in the dashboard

reddychaitu117
Loves-to-Learn Lots
<label>Test</label>
  <init>
    <unset token="msg"></unset>
    <unset token="form.msg"></unset>
    <set token="showResult">true</set>
  </init>
  <fieldset submitButton="false"></fieldset>
  <row>
    <panel id="logo">
      <html>
        <p>
          <img src="/static/app/CIS-CM)-CERT-Portal/cis-new.jpg" alt="Cis"/>
        </p>
      </html>
    </panel>
    <panel id="details">
      <html>
        <h>
          <b> Check Report</b>
        </h>
        <div id="desc">
          <p>
            This report displays the  Check details.
          </p>
        </div>
      </html>
    </panel>
  </row>
  <row>
    <panel id="hideshow">
      <html depends="$hideglo$">
        <a id="show">Show Filters</a>
      </html>
      <html rejects="$hideglo$">
          <a id="hide">Hide Filters</a>
      </html>
    </panel>
  </row>
  <row>
     <panel id="global" rejects="$hideglo$">
      <input type="dropdown" id="orgselect" token="org" searchWhenChanged="false">
        <label>Organization</label>
        <showClearButton>false</showClearButton>
        <search>
          <query>|  `orgList`</query>
          <earliest>0</earliest>
          <latest>now</latest>
        </search>
        <fieldForLabel>cust_name</fieldForLabel>
        <fieldForValue>cust_name</fieldForValue>
        <prefix>em7_cust_name="</prefix>
        <suffix>" em7_cust_name!=Cisco </suffix>
      </input>
      <input type="dropdown" id="region" token="region" searchWhenChanged="false">
        <label>Region*</label>
    <showClearButton>false</showClearButton>
        <selectFirstChoice>true</selectFirstChoice>
        <search>
          <query>
            |inputlookup cert_groups_lookup
            | lookup cert_servers_lookup group_id OUTPUTNEW em7_org_id
            | mvexpand em7_org_id
            | dedup em7_org_id,group_id
            | search em7_org_id="$cust_id$"
            | sort 0 group_name
          </query>
          <earliest>0</earliest>
          <latest>now</latest>
        </search>
        <fieldForLabel>group_name</fieldForLabel>
        <fieldForValue>group_id</fieldForValue>
        <prefix>group_id="</prefix>
        <suffix>"</suffix>
      </input>
Labels (1)
0 Karma

renjith_nair
Legend

Did you mean the drop down is not enabled to select?

If thats the case, check the search which populates the dropdown. If it uses the macros, then ensure that the user/app has permissions to access the macro and is expending the search

Happy Splunking!
0 Karma
Get Updates on the Splunk Community!

.conf24 | Registration Open!

Hello, hello! I come bearing good news: Registration for .conf24 is now open!   conf is Splunk’s rad annual ...

ICYMI - Check out the latest releases of Splunk Edge Processor

Splunk is pleased to announce the latest enhancements to Splunk Edge Processor.  HEC Receiver authorization ...

Introducing the 2024 SplunkTrust!

Hello, Splunk Community! We are beyond thrilled to announce our newest group of SplunkTrust members!  The ...