Building for the Splunk Platform

Why do we have to use "index=*" in our development environment, but not in production?

ajs
Engager

We have export and import some data from our production to development environment with same fields. But we found that "index=*" must be added to query in development environment. Could we know what we should set to make it the same as production? Thanks.

0 Karma
1 Solution

richgalloway
SplunkTrust
SplunkTrust

Verify the user roles are the same in PROD and DEV. It sounds like the DEV role does not have the same set of default indexes as the PROD role. Go to Settings->Access controls->Roles and select the appropriate role. Check the settings under "Indexes searched by default".

---
If this reply helps you, Karma would be appreciated.

View solution in original post

richgalloway
SplunkTrust
SplunkTrust

Verify the user roles are the same in PROD and DEV. It sounds like the DEV role does not have the same set of default indexes as the PROD role. Go to Settings->Access controls->Roles and select the appropriate role. Check the settings under "Indexes searched by default".

---
If this reply helps you, Karma would be appreciated.
Get Updates on the Splunk Community!

Set Up More Secure Configurations in Splunk Enterprise With Config Assist

This blog post is part 3 of 4 of a series on Splunk Assist. Click the links below to see the other ...

Observability Highlights | November 2022 Newsletter

 November 2022Observability CloudEnd Of Support Extension for SignalFx Smart AgentSplunk is extending the End ...

Enterprise Security Content Update (ESCU) v3.54.0

The Splunk Threat Research Team (STRT) recently released Enterprise Security Content Update (ESCU) v3.54.0 and ...