Building for the Splunk Platform

Cached search job not working in clustered environment

GindiKhangura
Explorer

I used JS to enable the cache flag on the searches running on my dashboard using the idea here (https://community.splunk.com/t5/Dashboards-Visualizations/Can-I-cache-searches-in-Simple-XML-using-t...).

It worked for me when I tested it on a standalone Splunk Enterprise environment. However, when I tried it in a clustered environment it did not work, though I do see that the flag is set to true when I inspect the search's JS object through the browser's developer tools.

The searches run after the flag is set (I use a token to control when it runs), so that isn't the issue.

Does anyone know what the issue could be or where to debug the issue?

-----

Notes:

  • Cannot use saved searches or report acceleration
  • Already using data model acceleration
Labels (3)
Tags (2)
0 Karma
Get Updates on the Splunk Community!

Security Highlights: September 2022 Newsletter

 September 2022 The Splunk App for Fraud Analytics (SFA) is now Splunk SupportedUse your existing Splunk ...

Platform Highlights | September 2022 Newsletter

 September 2022 What’s New in 9.0 and How to UpgradeGet a walk through of what is new Splunk Enterprise 9.0 ...

Observability Highlights | September 2022 Newsletter

 September 2022 Splunk Observability SuiteAccess to "Classic" SignalFx Interface Will be Removed on Sept 30, ...