Archive

two lines merged in one

New Member

Hi.

I have 2 events merged in one, they are the only two, the rest lines are perfectly shown. The interesting thing is that always the same hours appear there. 12:00:00 and 01:00:00

10/03/2010 12:00:00 AM,207.56920000000002,49.1489,103.25110000000001,52.4544,2.7146999999999997,5.0,5.0,5.0,0.0,0.0,0.0,0.0,0.0,0.0,0.0,0.0,0.0,5.0,0.0,0.0,0.0,0.0,0.0 10/03/2010 01:00:00 AM,219.39979999999997,106.60929999999999,71.8344,38.3043,2.6519000000000004,4.0,3.0,4.0,0.0,0.0,0.0,0.0,0.0,0.0,0.0,0.0,0.0,3.0,0.0,0.0,0.0,0.0,0.0

Those lines should be disappear as the rest of the rows contained in the given file.

Has Somebody an idea that what thing could be doing that????

Thanks a lot

0 Karma

Super Champion

Please update your questions and include your props.conf entry. (Use the "edit" link beneath your question.)

Off the top of my head, do you have SHOULD_LINEMERGE = False. That should ensure that your events are only ever a single line.


Update:

If you already have line merging disabled, then I would additional suggest making sure that your using an explicit timestamp format. Use the comment provided below as a starting point, I would suggest the following props.conf entry:

[csv-alex]
CHECK_FOR_HEADER = True
REPORT-AutoHeader = transform-alex
KV_MODE = none
SHOULD_LINEMERGE = false 
TIME_FORMAT = %m/%d/%Y %I:%M:%S %p
TIME_PREFIX = ^

Super Champion

Are you saying that you already had SHOULD_LINEMERGE as part of your settings and it still not working properly? If so, try adding an explicit TIME_FORMAT (see updated answer). Just to be clear, remember that any data indexed before making this change will not be effected my these changes. You will only see changes in newly indexed events (after a splunkd restart)

0 Karma

New Member

That is the props.conf

[csv-alex]
CHECK_FOR_HEADER = True
REPORT-AutoHeader = transform-alex
KV_MODE = none
SHOULD_LINEMERGE = false

0 Karma