Archive
Highlighted

search peers sick

Builder

Hi im having this issue :

The times on the system clocks for the machines running this search head and the intended search peer at uri=https://x.x.x.x:8089 differ from each other. You must make the times identical, so that time comparisons are valid across the deployment. skewseconds=-247. The max tolerable skew may be configured in [search]:maxtolerable_skew in limits.conf on the search head. Last Connect Time:2019-06-29T01:03:17.000-04:00; Failed 1 out of 1 times.

What's the root issue of this?

0 Karma
Highlighted

Re: search peers sick

SplunkTrust
SplunkTrust

@jadengoho ,
Are the search heads and indexers use same NTP servers? Worth to check the time on the hosts and make sure that they are ticking correctly

0 Karma
Highlighted

Re: search peers sick

Path Finder

This usually happens when your servers aren't connected to NTP server.
The server time of your search head and indexer starts to skew.

You can increase maxlorerableskew in limits.conf OR manually run the below command on all your splunk servers.
sudo date -s "29 JUN 2019 08:55:00".
Adjust time/date according to your time.

The best option is still to connect to NTP server as with the time fix, eventually down the line your time will get skewed again and you will have to run the date command again manually.

View solution in original post

Highlighted

Re: search peers sick

Builder

Hi, chin, this is Correct could you please change it to comment so I can approve it as the answer.
Also deleting and adding the peer again work sometimes.

0 Karma