Archive

"index=*" works but "*" does not

Contributor

What could be the reason why a search for "index=*" shows all expected events and "*" does not?

My indexes are full (contain events) and running (enabled).
They are mapped to the app "search" in the Manager > Indexes overview.

Tags (1)
0 Karma
1 Solution

Splunk Employee
Splunk Employee

Your events are in an index which is not listed as one of the default indexes to be searched. The default indexes to be searched are specified by role, and can be changed in Splunk Manager under the "Access Controls" section.

View solution in original post

Contributor

Thanks a lot!
I did not know that yet.
Did they change that in 4.2.1?
I am pretty sure that I did use "*" in a former installation without setting the several indexes as default for the admin user.

0 Karma

SplunkTrust
SplunkTrust

No, it's not new in 4.2.1, nor in 4.2

Splunk Employee
Splunk Employee

Your events are in an index which is not listed as one of the default indexes to be searched. The default indexes to be searched are specified by role, and can be changed in Splunk Manager under the "Access Controls" section.

View solution in original post