Archive

pdf report issue: landscape format and no csv data

karche
Path Finder

I schedule report and recevie mail from the pdf report server. However there are 2 issues.

  1. I selected the results in email as csv option in the configuration but the csv in the mail has no data
  2. the bar graph in the pdf only showed half of the data set but the UI shows 24 hours. How do i change this pdf report to landscape format? I couldnt find any charting option for that.

Thanks

Tags (1)

CerielTjuh
Path Finder

My collegue was searching for a way to change the layout of the page and in the current version (5.0.2) it is possible to change the layout to landscape in the scheduled search.

0 Karma

karche
Path Finder

I fixed the issue by editing the xml, adding the following option. I kept playing the numbers (170 in this case) and sent yourself email for testing to make sure the chart fit.

(0,170,10,0)

kjagpal
New Member

I have a report that has two sets of bar charts side by side showing data for last 7 days and both charts get chopped off using portrait (only shows 2 days of data). One chart has legend on bottom and the other has no legend. I had tried to use landscape and A0 paper size and it managed to show 6 days but still not enough to display all of the data. I've tried the workaround given above and no luck. I understand this is a bug. When is the issue going to be addressed?

0 Karma

ytamura
Path Finder

With regards to your second problem...
We used to have issues with graphs in PDFs, where only half of the data was visible in portrait format. I have not explored the option of using landscape, however the following 2 workarounds has been effective.

  1. If it's a timechart, for example going back 24 hours, instead of only defining earliest=-24h, do this earliest=-24h latest=24h. The chart will appear weird in your browser, but the PDF version will cut off the right half.

  2. Edit the xml to add a fake legend with huge width on the right. You'll have to play around with the numbers a little bit, but you can choose to either hide the legend or not, depending on where Splunk's PDF server cuts your chart...

    370
    right

ChrisG
Splunk Employee
Splunk Employee

Here's an answer about the page orientation part, from the Troubleshooting manual (http://docs.splunk.com/Documentation/Splunk/5.0/Troubleshooting/PDFTS#I.27m_getting_a_PDF_generated.... to set the page orientation to landscape, use Settings > Email settings (I think that's Manager > System Settings > Email Alert Settings).

ChrisG
Splunk Employee
Splunk Employee

Hi, I am not sure what is causing the problem. It's possible that you are transforming the data in some way that makes it not work in CSV. Without knowing more about your original search and what the results look like in table format, it's hard to say. You might want to ask for help on this through the IRC channel--or create a separate Answers posting that's just about the CSV export and includes more information about your search and results.

0 Karma

karche
Path Finder

Hi Chris, i select the "include results in email" either "As CSV" or "inline" still no data. May be report have 4 graphs?

0 Karma

ChrisG
Splunk Employee
Splunk Employee

Hi again--no, there is only the global setting; you can not set page orientation on a per-report basis.

For your CSV issue, it looks as if it doesn't work to select both CSV and PDF at the same time. If you check only "As CSV," you should get your data.

karche
Path Finder

Hi ChrisG, thanks for the reply. This setting will affect all the reports. Is there a setting for individual report?

0 Karma