Archive

/opt/splunk/bin/splunkd: error while loading shared libraries: libmongoc-1.0.so.0

New Member

Hi Guys.

I just installed splunk into a server with Ubuntu 14 OS. When I run sudo ./splunk start --accept-license I get the exception:

/opt/splunk/bin/splunkd: error while loading shared libraries: libmongoc-1.0.so.0: cannot open shared object file: No such file or directory
/opt/splunk/bin/splunkd: error while loading shared libraries: libmongoc-1.0.so.0: cannot open shared object file: No such file or directory
/opt/splunk/bin/splunkd: error while loading shared libraries: libmongoc-1.0.so.0: cannot open shared object file: No such file or directory
Did not find "disabled" setting of "kvstore" stanza in server bundle.

Some ideas for solving my problem?

0 Karma

Splunk Employee
Splunk Employee

Just in case someone else comes across this issue, the way I fixed this was to run 'sudo chown -R splunk:splunk /opt/splunk.

The issue started when I ran a setcap command.

New Member

running splunkd start instead of splunk start can cause libmongoc errors, per the answer here: https://answers.splunk.com/answers/46123/unable-to-install-splunk-4-3-1-119532-linux-i686.html

0 Karma
State of Splunk Careers

Access the Splunk Careers Report to see real data that shows how Splunk mastery increases your value and job satisfaction.

Find out what your skills are worth!