Archive
Highlighted

Your search did not return any events because you are in Smart Mode.

Communicator

@gcusello @richgalloway @woodcock
Your search did not return any events because you are in Smart Mode.
In what all scenarios do I get this?

Tags (2)
0 Karma
Highlighted

Re: Your search did not return any events because you are in Smart Mode.

SplunkTrust
SplunkTrust

Hello. You have asked for stats. In smart mode you won't see the actual events when you have | stats.

If you want to see the actual events as well as stats, switch to Verbose mode

The cool thing about Smart mode with stats is that it is quicker because the computation is performed by the indexers.

0 Karma
Highlighted

Re: Your search did not return any events because you are in Smart Mode.

Legend

@palisetty again refer to Splunk documentation first which should have answers to all your queries: https://docs.splunk.com/Documentation/Splunk/latest/Search/Changethesearchmode

Following is the summary of Search Modes taken from Splunk Documentation Splexicon:

1.Fast mode speeds up searches by limiting the types of data returned by the search.
2.Verbose mode returns as much event information as possible, at the expense of slower search performance.
3.Smart mode, the default setting, toggles search behavior based on whether your search contains transforming commands. For transforming searches, it behaves like Fast mode. For searches without transforming commands, it behaves like Verbose mode.




| eval message="Happy Splunking!!!"


View solution in original post