Archive
Highlighted

Splunk installation issues version 6.6.1

Motivator

Hi All, I have tried to install the splunk 6.6.1 version in VM Linux environment for a testing purpose and while extracting the splunk bundle got an error and soon after extracting the bundle, when tried to execute the ./splunk start --accept-license I am getting this error.

splunk bundle : splunk-6.6.1-aeae3fe0c5af-Linux-x86_64.tgz
OS version : OEL 6.5 (Oracle Enterprise Linux 64 bit)
RAM : 4GB

[root@lab bin]# ./splunk start --accept-license
This appears to be your first time running this version of Splunk.
/opt/splunk/bin/splunkd: error while loading shared libraries: libxmlsec1.so.1: cannot open shared object file: No such file or directory
/opt/splunk/bin/splunkd: error while loading shared libraries: libxmlsec1.so.1: cannot open shared object file: No such file or directory
/opt/splunk/bin/splunkd: error while loading shared libraries: libxmlsec1.so.1: cannot open shared object file: No such file or directory
Did not find "disabled" setting of "kvstore" stanza in server bundle.

Splunk> Take the sh out of IT.

Checking prerequisites...
/opt/splunk/bin/splunkd: error while loading shared libraries: libxmlsec1.so.1: cannot open shared object file: No such file or directory
Checking mgmt port [8089]: /opt/splunk/bin/splunkd: error while loading shared libraries: libxmlsec1.so.1: cannot open shared object file: No such file or directory
open
/opt/splunk/bin/splunkd: error while loading shared libraries: libxmlsec1.so.1: cannot open shared object file: No such file or directory
Checking kvstore port [8191]: /opt/splunk/bin/splunkd: error while loading shared libraries: libxmlsec1.so.1: cannot open shared object file: No such file or directory
open
/opt/splunk/bin/splunkd: error while loading shared libraries: libxmlsec1.so.1: cannot open shared object file: No such file or directory
Creating: /opt/splunk/var/lib/splunk
Creating: /opt/splunk/var/run/splunk
Creating: /opt/splunk/var/run/splunk/appserver/i18n
Creating: /opt/splunk/var/run/splunk/appserver/modules/static/css
Creating: /opt/splunk/var/run/splunk/upload
Creating: /opt/splunk/var/spool/splunk
Creating: /opt/splunk/var/spool/dirmoncache
Creating: /opt/splunk/var/lib/splunk/authDb
Creating: /opt/splunk/var/lib/splunk/hashDb
/opt/splunk/bin/splunkd: error while loading shared libraries: libxmlsec1.so.1: cannot open shared object file: No such file or directory
SSL certificate generation failed.

Kindly guide me how to trouble shoot this issue, so that I can install the splunk software in test environment.

Tags (2)
0 Karma
Highlighted

Re: Splunk installation issues version 6.6.1

New Member

Hi there, did you happen to get this fixed? Having the same issue.

0 Karma
Highlighted

Re: Splunk installation issues version 6.6.1

Motivator

Hi Kalmira, No I was unable to fix the issue, so could not proceed further, so did you get any solution to fix the issue.

thanks in advances.

0 Karma
Highlighted

Re: Splunk installation issues version 6.6.1

SplunkTrust
SplunkTrust

I don't know what version of linux the OEL is derived from, but have you tried just installing the libxmlsec1 library on the server? That seems to me to be the first course of action to take. I suspect that OEL decided not to install that library by default and that installing it should take care of your issue.

View solution in original post

0 Karma
Highlighted

Re: Splunk installation issues version 6.6.1

Motivator

Hi cpetterborg, thanks for your effort on this issue, i could successfully install the splunk 6.6.1 in our test machine. As you had commented that by installing the libxmlsec1-1.2.18-123.1.x86_64.rpm
file from this site. After installing the rpm, i could install and launch the splunk application.

http://rpm.pbone.net/index.php3/stat/4/idpl/23752033/dir/redhat_el_6/com/libxmlsec1-1.2.18-123.1.x86...

thanks

0 Karma
Highlighted

Re: Splunk installation issues version 6.6.1

SplunkTrust
SplunkTrust

I've converted the comment to an answer if you want to accept the answer so that others can easily find the answer to your question.

Thanks!

0 Karma
Highlighted

Re: Splunk installation issues version 6.6.1

New Member

Try running:

sudo ldconfig

DESCRIPTION

  • ldconfig creates the necessary links and cache to the most recent shared libraries found in the directories specified on the command line, in the file /etc/ld.so.conf, and in the trusted directories (/lib and /usr/lib). The cache is used by the run-time linker, ld.so or ld-linux.so. ldconfig checks the header and filenames of the libraries it encounters when determining which versions should have their links updated.
  • ldconfig will attempt to deduce the type of ELF libs (i.e., libc5 or libc6/glibc) based on what C libs, if any, the library was linked against.
  • Some existing libs do not contain enough information to allow the deduction of their type. Therefore, the /etc/ld.so.conf file format allows the specification of an expected type. This is used only for those ELF libs which we can not work out. The format is "dirname=TYPE", where TYPE can be libc4, libc5, or libc6. (This syntax also works on the command line.) Spaces are not allowed. Also see the -p option. ldconfig should normally be run by the superuser as it may require write permission on some root owned directories and files.

*This worked in our case after some back and forth with Splunk Support.

0 Karma
Highlighted

Re: Splunk installation issues version 6.6.1

Motivator

Hi Kalmira, thanks for your effort on this issue, i could successfully install the splunk 6.6.1 in our test machine. As cpetterborg had commented in his comments, that by installing the libxmlsec1-1.2.18-123.1.x86_64.rpm
file from this site had fixed the issue.
After installing the rpm, i could install and launch the splunk application.

http://rpm.pbone.net/index.php3/stat/4/idpl/23752033/dir/redhat_el_6/com/libxmlsec1-1.2.18-123.1.x86...

thanks

0 Karma