Splunk archiving setting not working properly


I am testing the frozenTimePeriodInSecs setting, I have following default stanza in my indexes.conf file.

frozenTimePeriodInSecs = 31556736

Still all the indexes are showing data that is older than 7 years.
I was expecting data older than a year to be deleted as I don't have any archive directory setup.
There are two things that could be possible - either the default setting is not being applied to all the indexes or the frozenTimePeriodInSecs setting is not working as expected for me.

Has anyone else faced a similar situation ? Are there any configurational settings I am missing ?

0 Karma


hey, I think you have configured indexes.conf in default?

default is the name of the index?

can you tell where you have configured this setting?

This is found in indexes.conf and is set on a per-index level.

The parameter is called FrozenTimePeriodInSecs and is expressed in seconds. If it does not exist, then the default value of 31556736 is used, which is approximately 6 years.

Read more in the docs,

you have to configure this in local/indexes.conf

If default is not the name of the index then the syntax should be

frozenTimePeriodInSecs = 31556736

let me know if this helps!

0 Karma


Hi Mayur,
Thanks for your reply.
I tried adding the line for individual indexes to archive data by adding coldToFrozenDir settings in local/indexes.conf. We have 10TB of data to be archive but the rate of archiving was very very slow around 1GB/day.
Have you tried this in the past ?

0 Karma