Archive

Splunk DB Connect MSSQL Problem

Path Finder

Hi

I'm having the problem that I can not connect a mssql database with the splunk db connect app. If I want to connect the database via the GUI splunk gives me the following message each time:

Encountered the following error while trying to save: Splunkd daemon is not responding: ('The read operation timed out',)

There is no firewall between the db and the splunk server from which I would connect. I've tested this with telnet. I also fill in all required disclosures, such as the port (1436), the hostname (example.bla.ch), the database (someinstance/northwind), the user, the database-type (Microsoft SQL Server) and the password. The user can log directly into the db, this I've also tested. The user has read permissions.

In the dbx.log on the system I find no log entries which indicate an error.

Any help would be greatly appreciated.
Cheers,
Yanick

1 Solution

Path Finder

Hi

The problem was on the MSSQL database. Because the encryption was configured on the database the JDBC had problems with the connection.

It is known that the JDBC has problems with this setting. A solution to the problem I have not found it yet. We have simply taken this configuration out on the database. Now it works.

Cheers,
Yanick

View solution in original post

0 Karma

Path Finder

Has there been any updates to this issue using DB Connect 1 or 2?

0 Karma

New Member

hi alonalonalon,

AM using JRE 7 and still have this issue, any advice ?

0 Karma

Engager

it took me two days to figure it out, but i finally got it to work by using JRE 7 rather than JRE 8
THIS IS THE ANSWER TO MOST OF YOUR DATABASE CONNECTION ISSUES !!!!

New Member

hi alonalonalon,

AM using JRE 7 and still have this issue, any advice ?

0 Karma

Splunk Employee
Splunk Employee

Great find! Just saved me precious time. Thank you!

0 Karma

Path Finder

Hi

The problem was on the MSSQL database. Because the encryption was configured on the database the JDBC had problems with the connection.

It is known that the JDBC has problems with this setting. A solution to the problem I have not found it yet. We have simply taken this configuration out on the database. Now it works.

Cheers,
Yanick

View solution in original post

0 Karma

Path Finder

please suggest me i am having the same problem which settings i have to remove .

0 Karma

New Member

Am having similar issue ?, How do I check if the database is configured for encryption ?

0 Karma

Explorer

What configuration setting did you remove?

0 Karma

Super Champion

I have mssql connections working with 2K8R2, so yes they work.
I've had similar trouble getting a connection to work, and the problems were solved with a little troubleshooting.

1) The default port for mssql is 1433. I'm assuming you changed it to 1436.
2) Check the logs. The application log on the db server will have SourceName=MSSQLSERVER entries that should be picking up the connection failure.
3) You should also check the dbx, and splunkd logs on the indexer.

0 Karma

Path Finder

Hi

I'm having an another question about the problem that I have. The database is a MSSQL 2008 R2. Is this database supported by the splunk db connector?

Any help would be greatly appreciated.
Cheers,
Yanick

0 Karma