Archive

Misconfigured view error after upgrade to 4.2.3

Engager

I upgraded from 4.2.2 to 4.2.3 (Windows). After the upgrade, this message appears in the top of my browser:

Misconfigured view 'search_ui_activity' - Unknown parameter 'suppressionList' is defined for module ViewstateAdapter. Make sure the parameter is specified in ViewstateAdapter.conf.

Anyone know what to do about that?

0 Karma
1 Solution

Splunk Employee
Splunk Employee

Check your ViewstateAdapter.conf in $SPLUNK_HOME/share/splunk/search_mrsparkle/modules/results . Does it have a...

[param:suppressionList]

required = false

...stanza?

View solution in original post

Splunk Employee
Splunk Employee

My guess is that this is a problem with how Simple XML converts to Advanced XML. If you add "&showsource=1" to the end of the URL, you can grab the converted advanced XML, paste it into a new view, remove the suppressionList param for ViewstateAdapter, and then see if the issue goes away.

Splunk Employee
Splunk Employee

I did as you said, and added this stanza to the ViewstateAdapter.conf file, but even after restarting splunk i still get the error.

I am using advanced XML. Any ideas??

0 Karma

Splunk Employee
Splunk Employee

What view is this? Is this simple or advanced XML?

0 Karma

Splunk Employee
Splunk Employee

Check your ViewstateAdapter.conf in $SPLUNK_HOME/share/splunk/search_mrsparkle/modules/results . Does it have a...

[param:suppressionList]

required = false

...stanza?

View solution in original post

Splunk Employee
Splunk Employee

So was it simple or advanced XML? In other words, which view was this?

0 Karma

Engager

It did not. I added that, and the message went away. Thanks!

0 Karma