Archive
Highlighted

Lookup File Lookup in props\transform

Path Finder

We are using graylog to forward windows security events to SPLUNK, since we are using Enterprise Security and COM and we worked with SPLUNK PS to basically remap the fields from winlogbeat_ to format needed by the SPLUNKTAwindows app. We have these working but are struggling with 1 lookup.

The field is 'action' with a value of "Action Success" or "Action Failure". However, when graylog sends it as [Action Success] or [Action Failure]. We changed the lookups file from splunktawindows to [Action Success], success or [Action Failure],failure.

It doesn't appear to pull this from the lookup table. Is there a particular format when prefaced with a special character?

Here is what I tried:

[audit failure],failure
[Audit Failure],failure
"[AUDIT_FAILURE]",failure

Thanks!

Not sure if this is conflicting with the TA_Windows lookup or not, when I look at a btool I see that mine loaded, but I would think if I was using that one it would have broken the events coming in over the SPLUNK UF.

Tags (1)
0 Karma
Highlighted

Re: Lookup File Lookup in props\transform

Ultra Champion

Can you not update your extractions to strip off those square brackets before the lookup is applied?

0 Karma
Highlighted

Re: Lookup File Lookup in props\transform

Path Finder

Thanks Frank, I did try that but was not successful. What my issue was the SplunkTAwindows lookup was taking precedence so I just called it another name it works.

0 Karma