Archive
Highlighted

Is pod splunk mint 4.2.1 compatible with ios 7.x ans ios 6.x?

Engager

Is pod splunk mint 4.2.1 compatible with ios 7.x ans ios 6.x?

in the documentation states tah is compatible with ios > 6
Documentation latest

but when i run pod install

[!] The platform of the target `App` (iOS 7.0) may not be compatible with `SplunkMint (4.2.1)` which has a minimum requirement of iOS 8.0.

In the podspec it states platform ios 8.0
https://github.com/CocoaPods/Specs/blob/master/Specs/SplunkMint/4.2.1/SplunkMint.podspec.json

Should we change the podSpec or is incompatible with ios 7?

Tags (3)
0 Karma
Highlighted

Re: Is pod splunk mint 4.2.1 compatible with ios 7.x ans ios 6.x?

New Member

Someone please answer this? i am delaying a deployment for this answer...

0 Karma
Highlighted

Re: Is pod splunk mint 4.2.1 compatible with ios 7.x ans ios 6.x?

Influencer

I am not an iOS developer, so I'm not familiar with CocoaPods. The spec file you linked does not seem to be authored by Splunk, but it seems to be pulling from Splunk's download server so unless it's omitting something I would trust the Splunk MINT SDK for iOS Developer Guide which states:

The Splunk MINT SDK for iOS supports the following:

  • iOS versions 6.x, 7.x, and 8.x.
  • ARMv7, ARMv7s, and ARM64 architectures
  • The iOS Simulator
0 Karma
Speak Up for Splunk Careers!

We want to better understand the impact Splunk experience and expertise has has on individuals' careers, and help highlight the growing demand for Splunk skills.