Archive

How to connect splunk to the internet via Proxy on Windows

Explorer

Hi there,

I have a Splunk Server running on Windows and want to use the integrated App-Update-Checking. To accomplish this task I have to go via our companys webproxy.

According to this documentation I have to set the http_proxy variable in my splunk-launch.conf file.

Unfortunately this doesn't work, if I click on "Find more Apps online" etc my Splunk Box still tries to connect directly and not via the Proxy.

Has anyone got this working? Any help would be appreciated.

Thanks in Advance
Daniel

Tags (1)
0 Karma
1 Solution

Explorer

I got it fixed: Had to set httpS_proxy = : sigh 🙂

View solution in original post

Explorer

I got it fixed: Had to set httpS_proxy = : sigh 🙂

View solution in original post

Builder

Yes, this proxy setting in splunk-launch.conf is working in my labo. To reflect the setting, restarting splunk is required. Did you restart splunk? And also please confirm if splunk server itself is actually able to connect the proxy server. You may also need to make proxy server allow source ip address of splunk server.

0 Karma

Builder

Strange.. I think it could be bug. You can ask splunk officail support team.

0 Karma

Explorer

Hmm, actually I restarted the splunkd service aswell as the splunkweb service multiple times without luck. Setting our proxy in ie also works without problems.

At first I thought it might have to do with our proxy-authentication requirement but in the firewall-logs I saw that splunk wants to connect directly to splunk.com and not to the proxy-ip.

My splunk-launch.conf looks like this:

http_proxy = 10.1.0.24:8080

I also tried things like "http://ip:port" without success.

On my linux-splunk-testbox I got it working by setting the Environment Variable HTTP_PROXY=http://10.1.0.24:8080

Engager

I am having the same issue, did you manage to get this to work?

0 Karma