Archive
Highlighted

How do I resolve Hunk error "Virtual index provider stanza=provider:myindex is missing required parameter "vix.family""?

Contributor

Hi

I have a problem in Hunk.

Index problem:

Cannot load IndexConfig: Found 1 configuration issue: Issue 1: Virtual index provider stanza=provider:myindex is missing required parameter "vix.family".

I don't know what I should to do, I'm desperate 😞

Tags (3)
0 Karma
Highlighted

Re: How do I resolve Hunk error "Virtual index provider stanza=provider:myindex is missing required parameter "vix.family""?

SplunkTrust
SplunkTrust

You need to add vix.family = <family> to your indexes.conf:

vix.family = <family>
* A provider family to which this provider belongs.
* The only family available by default is "hadoop". Others may be added.

http://docs.splunk.com/Documentation/Splunk/6.4.1/admin/indexesconf#PER_PROVIDER_OPTIONS

0 Karma
Highlighted

Re: How do I resolve Hunk error "Virtual index provider stanza=provider:myindex is missing required parameter "vix.family""?

Contributor

when i restart splunk i get a probleme

i just delete a newest projet and reload splunk and the problem solved.

thx for reply

View solution in original post

0 Karma
Speak Up for Splunk Careers!

We want to better understand the impact Splunk experience and expertise has has on individuals' careers, and help highlight the growing demand for Splunk skills.