Archive

How can I display custom polygon shapes on Choropleth maps?

Path Finder

I've uploaded a KMZ file as a lookup file and created the lookup definition; however, when I try to test it, the search says it's finalizing but never completes and does no display a map.

I'm not sure I got the xpath formatted correctly. Below is a sample from the KML file and the XPATH I used.

Any Ideas?

The featureIdField that I want is at the end of the sample and is:

<value>A - Regional Choice</value>

XPATH:

/kml[@xmlns:kml="http://earth.google.com/kml/2.2"]/Document[@id="featureCollection"]/Folder/Placemark/ExtendedData/Data[25]/value/text()

Sample from KML File:

<?xml version='1.0' encoding='UTF-8'?>
<kml xmlns:kml="http://earth.google.com/kml/2.2">
  <Document id="featureCollection">
<Style id="defaultStyle">
  <LineStyle>
    <width>1.5</width>
  </LineStyle>
  <PolyStyle>
    <color>7d8a30c4</color>
  </PolyStyle>
</Style>
  <Folder><Placemark>
      <styleUrl>#defaultStyle</styleUrl>

      <ExtendedData>
        <Data name="cfc1214_ci"><value>11.0</value></Data><Data name="phoo_hu_14"><value>0.72989377845</value></Data><Data name="pcin_14_ci"><value>0.0772164978</value></Data><Data name="chuo_14_ci"><value>659.0</value></Data><Data name="cvac_14_ci"><value>3.0</value></Data><Data name="msp1214_ci"><value>242500.0</value></Data><Data name="husqmi14ci"><value>15330.298244</value></Data><Data name="churo_14_c"><value>178.0</value></Data><Data name="clusterlet"><value>A</value></Data><Data name="cvalt14_ci"><value>3.0</value></Data><Data name="geoid10"><value>245100101001</value></Data><Data name="landsqmile"><value>0.043052</value></Data><Data name="csp1214_ci"><value>130.0</value></Data><Data name="shape_area"><value>0.0000116407</value></Data><Data name="sp_estimat"><value>0.0</value></Data><Data name="shape_leng"><value>0.01550170555</value></Data><Data name="cpa1214_gt"><value>58.0</value></Data><Data name="pvlot14_ci"><value>0.00470219436</value></Data><Data name="pvac_14_ci"><value>0.00472440945</value></Data><Data name="chuoo_14_c"><value>481.0</value></Data><Data name="vsp1214_ci"><value>0.38502451782</value></Data><Data name="pfchu1214"><value>0.01732283465</value></Data><Data name="ppa1214_gt"><value>0.09133858268</value></Data><Data name="chu_14_ci"><value>660.0</value></Data><Data name="hmt"><value>A - Regional Choice</value></Data>
      </ExtendedData>
0 Karma

Splunk Employee
Splunk Employee
0 Karma

Splunk Employee
Splunk Employee

Hi @digital_alchemy,
In case you haven't already, you could take a look at this docs topic on setting up a geospatial lookup. It sounds like you might need to double-check the lookup definition and the XPath expression. There are some examples in this topic that could help:

http://docs.splunk.com/Documentation/Splunk/6.6.0/Knowledge/Configuregeospatiallookups

0 Karma