Archive
Highlighted

Filler gauge not displaying percentage properly

Path Finder

My raw data:

Filesystem                                Type              Size        Used       Avail      UsePct    MountedOn
/dev/xvda                                 ext3               16G        2.3G         13G         16%    /
/dev                                      devtmpfs          249M        4.0K        249M          1%    /dev

My search:

host="server1" source="df" | gauge usedPct

My results:

x
16%

Upon trying to chart this in any gauge format it displays as 0. Do I need to somehow convert this "16%" to just "16" in order for the gauge to work? Perhaps it thinks it's a string, how would I convert it to an integer? "gauge tonumber(usedPct)" does not return results...

Tags (1)
0 Karma
Highlighted

Re: Filler gauge not displaying percentage properly

Splunk Employee
Splunk Employee

Yes, gauge is expecting a number. I think you could use 'trim' to get rid of the '%' and then convert it to a number.

... | eval myString = trim(usedPct, "%") | eval myNum = tonumber(myString) | gauge myNum

View solution in original post

Highlighted

Re: Filler gauge not displaying percentage properly

Path Finder

Worked like a charm! Thanks!

0 Karma
Highlighted

Re: Filler gauge not displaying percentage properly

Contributor

I know this is old, but a shorter way to do this is:
host="server1" source="df" usedPct | eval usedPct = trim(usedPct, "%")

This will allow you to keep the original column, just reformatted without percent, rather than creating a new field called "myString"

0 Karma