Archive
Highlighted

Failing to enable boot-start with user parameter

Path Finder
root@splunk:/usr/src# dpkg -i splunk-4.2-96430-linux-2.6-amd64.deb
Selecting previously deselected package splunk.
(Reading database ... 48824 files and directories currently installed.)
Unpacking splunk (from splunk-4.2-96430-linux-2.6-amd64.deb) ...
Setting up splunk (4.2-96430) ...
----------------------------------------------------------------------
Splunk has been installed in:
        /opt/splunk

To start Splunk, run the command:
        /opt/splunk/bin/splunk start

To use the Splunk Web interface, point your browser at:
        http://apa-splunk-04:8000

Complete documentation is at http://www.splunk.com/r/docs

root@apa-splunk-04:/usr/src# /opt/splunk/bin/splunk start
SPLUNK SOFTWARE LICENSE AGREEMENT
[..]
 "Splunk Developer API" means the documentation and functionality enabling
Do you agree with this license? [y/n]: y

This appears to be your first time running this version of Splunk.
Copying '/opt/splunk/etc/openldap/ldap.conf.default' to '/opt/splunk/etc/openldap/ldap.conf'.
Generating RSA private key, 1024 bit long modulus
[..]
The Splunk web interface is at http://splunk:8000

root@splunk:/usr/src# /opt/splunk/bin/splunk enable boot-start -user splunk
bash: splunk: command not found
First-time-run has not finished.  Ignore this error when previewing migration - exiting.

Any idea why it is failing? It is also giving wrong error message

"bash: splunk: command not found"

root@splunk:/usr/src# /opt/splunk/bin/splunk --version
Splunk 4.2 (build 96430)

root@splunk:/usr/src# getent passwd splunk
splunk:x:1001:1001:Splunk Server:/opt/splunk:/bin/bash
Tags (1)
Highlighted

Re: Failing to enable boot-start with user parameter

Communicator

Did you update $SPLUNK_HOME/etc/splunk-launch.conf ?

0 Karma
Highlighted

Re: Failing to enable boot-start with user parameter

Path Finder

no I did not. It is default.

0 Karma
Highlighted

Re: Failing to enable boot-start with user parameter

New Member

Was there any resolution to this issue? I have run into the same issue, from the error I am guessing there is a script somewhere that is assuming splunk is on the path directly.

0 Karma