Archive
Highlighted

Events don't show up in Search when the time range preset is "All Time"

Explorer

I'm using the splunk version 6.0.5.

I pushed some data containing events of time stamp of last year (04/2014).

However events doesn't show up in the search which has time presets set to "All Time" by default

When I change the presets to Date range some thing like 04/06/2014 to 04/10/2014, the events show up in the search.

Does any body have idea of why the events won't show up in the "All Time" preset?

Tags (2)
0 Karma
Highlighted

Re: Events don't show up in Search when the time range preset is "All Time"

Path Finder

Just a guess, but do you have permission to search the time range?

0 Karma
Highlighted

Re: Events don't show up in Search when the time range preset is "All Time"

Explorer

Yes. I have access to specify time range. How does this info help?

0 Karma
Highlighted

Re: Events don't show up in Search when the time range preset is "All Time"

Path Finder

Sorry for the confusion, let me clarify. If your access level only allows a search for 30 days, you won't be able to see the "All Time" results. The "All Time" results would fall out of the range for the 30 day period.

Hope that helps.

0 Karma
Highlighted

Re: Events don't show up in Search when the time range preset is "All Time"

Contributor
  1. Make sure you are using the right index as your data may be in 'x-index' as splunk default index is 'main' so include your search with respective index and sourcetype too in .And you must have access to those indexes..
  2. Make sure your Indexer or search peers are active(Seach head able to fetch data from it)
  3. Check in inputs.conf too..
  4. If possible check the timestamp in logs and search for that specific time range instead of all time.
0 Karma