Archive

Connect to SQL Azure version 11.0.9149

terrencebenade
Explorer

Today we found out we cannot connect to SQL Azure version 11.0.9149. We can connect to instances in the same data centre running version 11.0.9041

Running 5.04 connecting using Splunk DB Connect. Any clue as to how I can get this to work?

1 Solution

afoote_splunk
Splunk Employee
Splunk Employee

The default jTDS driver that ships with DBConnect for MS SQL doesn't work with this version of Azure (Premium). The jTDS driver does however work with Azure standard.

To enable connection ...

Download the MSoft jdbc driver (V 4) from Microsoft and drop into /opt/splunk/etc/apps/dbx/bin/lib directory.

Then update /opt/splunk/etc/apps/dbx/local/database_types.conf by appending the following stanza...

[sqlazure]
displayName = SQLAzure
jdbcDriverClass = com.microsoft.sqlserver.jdbc.SQLServerDriver
defaultPort = 1433
connectionUrlFormat = jdbc:sqlserver://{0}:{1};databaseName={2}
testQuery = SELECT 1 AS test

Restart splunk and navigate to "Splunk DB Connect".
Select "Database connections in Splunk Manager" and ensure your connection has Database Type set to SQLAzure (should now be available from dropdown menu)

You should now be able to connect to this instance of Azure ...

View solution in original post

afoote_splunk
Splunk Employee
Splunk Employee

The default jTDS driver that ships with DBConnect for MS SQL doesn't work with this version of Azure (Premium). The jTDS driver does however work with Azure standard.

To enable connection ...

Download the MSoft jdbc driver (V 4) from Microsoft and drop into /opt/splunk/etc/apps/dbx/bin/lib directory.

Then update /opt/splunk/etc/apps/dbx/local/database_types.conf by appending the following stanza...

[sqlazure]
displayName = SQLAzure
jdbcDriverClass = com.microsoft.sqlserver.jdbc.SQLServerDriver
defaultPort = 1433
connectionUrlFormat = jdbc:sqlserver://{0}:{1};databaseName={2}
testQuery = SELECT 1 AS test

Restart splunk and navigate to "Splunk DB Connect".
Select "Database connections in Splunk Manager" and ensure your connection has Database Type set to SQLAzure (should now be available from dropdown menu)

You should now be able to connect to this instance of Azure ...

View solution in original post

terrencebenade
Explorer

Worked a treat thank you!

0 Karma

roopasree
Engager

@terrencebenade

Hi,will you please help make to make the connection I tried the above one but I did't get it.

Thank You.

0 Karma

DerekKing
Path Finder

Appreciate this is an old post now, but I have exactly the same problem.

I've placed the sqljdbc & sqljdbc4.jar files into the bin/lib directory, and amended the stanza, but when trying to add the database, I get the message

Encountered the following error while trying to save: In handler 'databases': Error connecting to database: java.sql.SQLException: No suitable driver found for jdbc:server

Has anyone else had this issue or resolved it ?

Derek

0 Karma

halr9000
Motivator

@derekking, sounds like your best bet here is to create a whole new question, citing this error message at the top. Nobody will find you down here in a comment to an old and answered question, except for the guy who posted the question, the one who posted the answer to which you replied, plus anyone who followed it, like me. Much more visibility to make a new Q, especially since you've actually got a new problem.

0 Karma