Archive
Highlighted

Cisco ACI for splunk error when trying to add APIC

Engager

Hi All,

I am receiving the below error hen trying to add an APIC on my splunk instance.

Encountered the following error while trying to update: Error while posting to url=/servicesNS/nobody/TAcisco-ACI/admin/ciscoaciserversetup/ciscoaciserversetupsettings

Any idea on how this can be solved?

Tags (1)
Highlighted

Re: Cisco ACI for splunk error when trying to add APIC

Splunk Employee
Splunk Employee

This is late, but I took this from someone having the same issue with the TA for Cisco IPS. This only happened after I forgot to disable SSL.

Regardless, this worked for me

Navigate to $SPLUNKHOME/etc/apps/TAcisco-ACI

Remove app.conf
Remove passwords.conf

Try again

0 Karma
Highlighted

Re: Cisco ACI for splunk error when trying to add APIC

New Member

Did you find a solution for this problem that you can share?

I am running into the same problem,

This Path does not exist under splunk directory:
url=/servicesNS/nobody/TAcisco-ACI/admin/ciscoaciserversetup/ciscoaciserversetupsettings

0 Karma
Highlighted

Re: Cisco ACI for splunk error when trying to add APIC

New Member

I have the same problem, how to disable the ssl to be verified?

0 Karma
Highlighted

Re: Cisco ACI for splunk error when trying to add APIC

New Member

Hi,

Unfortunately i have faced with same error when adding aci controller in fresh installation.
I have tried to find files and was able to find only app.conf. There is no file passwords.conf.
I guess it is because the installation and configuration is not over yet.

So, would be appreciated for any solution.

Thanks,

0 Karma
Highlighted

Re: Cisco ACI for splunk error when trying to add APIC

New Member

Hi,

i have the same issue.

I downloaded Cisco ACI Add-on for Splunk Enterprise 4.2.1 and Cisco ACI App for Splunk Enterprise 4.2.4 on a 6.6.6 Splunk server version.

each time i tried to install the add-on SSL dsable checked or uncheched or disable i have the same error :

"Error while posting to url=/servicesNS/nobody/TAcisco-ACI/admin/ciscoaciserversetup/ciscoaciserversetupsettings".

There is no "app.conf" or "passwords.conf" file in $SPLUNKHOME/etc/apps/TAcisco-ACI.

any idea ???

0 Karma
Highlighted

Re: Cisco ACI for splunk error when trying to add APIC

New Member

try to use the last version and follow the instructions and it will work :

  • Follow below steps to disable the SSL verification:
    • For Password based Authentication and Remote User based Authentication:
    • Provide credentials from setup page.
    • passwords.conf file will be created in TA_cisco-ACI/local folder with sample stanza : [credential:x.x.x.x:,admin,True:].
    • Here, default value of SSL verification will be True.
    • Change this value from True to False.
    • Restart Splunk.
0 Karma
Highlighted

Re: Cisco ACI for splunk error when trying to add APIC

Communicator

Hi,

I am getting below error after installation . I am using password based authentication and i have changed ssl from true to false in passwords.conf file and then restarted splunk . but of no use.

message from "/applis/LMD/splunk/bin/python2.7 /applis/LMD/splunk/etc/apps/TAcisco-ACI/bin/collect.py -authentication aaaSessionLR" ACI Error: Could not get TAcisco-ACI credentials from splunk. Error: Splunkd daemon is not responding: ('Error connecting to /services/admin/passwords: [Errno 111] Connection refused',)

Please help

0 Karma