Archive

Can't display Search/Dashboards/Reports

Communicator

When I enter my app, I can't see any of them.. I see "500 Internal Server Error" instead.

Traceback from _internal index:

2016-05-31 10:45:18,971 DEBUG   [574d4f1e897f7ed4762f50] _cplogging:55 - [31/May/2016:10:45:18] HTTP Traceback (most recent call last): File "/raid/splunk-sh/lib/python2.7/site-packages/cherrypy/_cprequest.py", line 606, in respond cherrypy.response.body = self.handler() File "/raid/splunk-sh/lib/python2.7/site-packages/cherrypy/_cpdispatch.py", line 25, in __call__ return self.callable(*self.args, **self.kwargs) File "/raid/splunk-sh/lib/python2.7/site-packages/splunk/appserver/mrsparkle/lib/routes.py", line 366, in default return route.target(self, **kw) File "<string>", line 1, in <lambda> File "/raid/splunk-sh/lib/python2.7/site-packages/splunk/appserver/mrsparkle/lib/decorators.py", line 38, in rundecs return fn(*a, **kw) File "<string>", line 1, in <lambda> File "/raid/splunk-sh/lib/python2.7/site-packages/splunk/appserver/mrsparkle/lib/decorators.py", line 118, in check return fn(self, *a, **kw) File "<string>", line 1, in <lambda> File "/raid/splunk-sh/lib/python2.7/site-packages/splunk/appserver/mrsparkle/lib/decorators.py", line 167, in validate_ip return fn(self, *a, **kw) File "<string>", line 1, in <lambda> File "/raid/splunk-sh/lib/python2.7/site-packages/splunk/appserver/mrsparkle/lib/decorators.py", line 335, in preform_sso_check return fn(self, *a, **kw) File "<string>", line 1, in <lambda> File "/raid/splunk-sh/lib/python2.7/site-packages/splunk/appserver/mrsparkle/lib/decorators.py", line 387, in check_login return fn(self, *a, **kw) File "<string>", line 1, in <lambda> File "/raid/splunk-sh/lib/python2.7/site-packages/splunk/appserver/mrsparkle/lib/decorators.py", line 407, in handle_exceptions return fn(self, *a, **kw) File "<string>", line 1, in <lambda> File "/raid/splunk-sh/lib/python2.7/site-packages/splunk/appserver/mrsparkle/lib/decorators.py", line 462, in apply_cache_headers response = fn(self, *a, **kw) File "/raid/splunk-sh/lib/python2.7/site-packages/splunk/appserver/mrsparkle/controllers/view.py", line 1061, in render can_alert, searches = self.get_saved_searches(app) File "/raid/splunk-sh/lib/python2.7/site-packages/splunk/appserver/mrsparkle/controllers/view.py", line 898, in get_saved_searches searches = en.getEntities('saved/searches', namespace=app, search='is_visible=1 AND disabled=0', count=500, _with_new='1') File "/raid/splunk-sh/lib/python2.7/site-packages/splunk/entity.py", line 131, in getEntities offset = int(atomFeed.os_startIndex or -1) AttributeError: 'str' object has no attribute 'os_startIndex'
0 Karma
1 Solution

Communicator

My search included a custom char (http://www.fileformat.info/info/unicode/char/ffff/index.htm), and I saved this search as a report.

After removing it from savedsearches.conf and refreshing splunk (splunk _internal call "/admin/savedsearch/_reload") it started to work.

I think that it is a Splunk bug and should be fixed.

View solution in original post

0 Karma

Communicator

My search included a custom char (http://www.fileformat.info/info/unicode/char/ffff/index.htm), and I saved this search as a report.

After removing it from savedsearches.conf and refreshing splunk (splunk _internal call "/admin/savedsearch/_reload") it started to work.

I think that it is a Splunk bug and should be fixed.

View solution in original post

0 Karma