Archive
Highlighted

Can ignoreOlderThan have a 'disabled' value? 0d is reported as invalid

New Member

In our inputs.conf we have a default ignoreOlderThan=3d value set, but I would like to override that default for a specific monitor (source) entry. I have tried using ignoreOlderThan=0d as well as ignoreOlderThan=disabled but they both result in an "Invalid value for parameter 'ignoreOlderThan'" error in the splunkd.log.

Is there a value that equates to disabling the ignoreOlderThan setting for a specific monitor/source without applying it to the entire inputs.conf?

0 Karma
Highlighted

Re: Can ignoreOlderThan have a 'disabled' value? 0d is reported as invalid

SplunkTrust
SplunkTrust

Use ignoreOlderThan = to unset the attribute. If that doesn't work, use a very high value like ignoreOlderThan = 1000d.

---
If this reply helps you, an upvote would be appreciated.
0 Karma