Archive

App launcher screen is blank

Explorer

I've just installed Splunk on 64-bit Solaris 10.

The install was successful, and I've started splunk using the CLI command.

However, after logging in, http://servername:8000/en-US/app/launcher/home shows a blank page.

I've tried this in Chrome and Firefox, and also restarted both splunkd and splunkweb, but the problem persists.

Any idea what the problem could be?

The page source does show some HTML, posted below in case it's useful:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xmlns:s="http://www.splunk.com/xhtml-extensions/1.0" xml:lang="en" lang="en">
<!-- live to code, code to live... -->

    <head>
        <meta http-equiv="X-UA-Compatible" content="IE=7, IE=9, chrome=IE8" />
        <meta http-equiv="content-type" content="text/html; charset=utf-8" />
        <meta http-equiv="content-language" content="en_US" />
        <meta http-equiv="imagetoolbar" content="no" />
        <meta name="author" content="Splunk Inc." />
        <link rel="apple-touch-icon" href="/en-US/static/@123586/img/iosicon.png" />
        <link rel="shortcut icon" href="/en-US/static/@123586/img/favicon.ico" />
        <title>
    (home) - Home - Splunk 4.3.2
</title>



            <script type="text/javascript" src="/en-US/config?autoload=1&namespace=launcher"></script>             




                <script type="text/javascript" src="/en-US/static/@123586/js/common.min.js"></script>                 





            <link rel="stylesheet" href="/en-US/static/@123586/css/view.css" />             
            <link rel="stylesheet" href="/en-US/static/@123586/css/skins/default/default.css" />             
            <link rel="stylesheet" href="/en-US/static/@123586/css/print.css" />             
            <link rel="stylesheet" href="/en-US/static/@123586/css/tipTip.css" />             
            <link rel="stylesheet" href="/en-US/static/@123586/css/jquery.iphone-style-checkboxes.css" />             








            <link rel="stylesheet" href="/en-US/static/@123586:0/app/launcher/application.css" />             







    </head>


    <body class="splTemplate-search splView-home splApp-launcher splVersion-4 splVersion-4_3 splVersion-4_3_2" s:app="launcher" s:view="home" s:displayview="home" s:onunloadcanceljobs="True" s:autocancelinterval="90">







<div id="loading">Loading...</div>
<div class="layout">









        <div class="layoutRow oneColRow splClearfix messaging">

    <div class="SplunkModule Message"                id="Message_0_0_0"        >    </div>


        </div>



<div class="appHeaderWrapper">



        <div class="layoutRow oneColRow splClearfix navigationHeader">

    <div class="SplunkModule AccountBar"                id="AccountBar_0_0_0"        >    </div>


    <div class="SplunkModule AppBar"                id="AppBar_0_0_0"        >    </div>


        </div>

</div>








    <div class="layoutRow noSidebar resultsArea splClearfix">


        <div class="layoutRow oneColRow">


    <div class="SplunkModule ServerSideInclude"                id="ServerSideInclude_0_0_0"        >    </div>


        </div>


</div>



</div>













































    <script type="text/javascript">
    //<![CDATA[
    Splunk.Module.loadParams  = {"Message_0_0_0": {"filter": "*", "clearOnJobDispatch": "False", "maxSize": "1"}, "AccountBar_0_0_0": {}, "ServerSideInclude_0_0_0": {"src": "launcher.html"}, "AppBar_0_0_0": {}};
    Splunk.Module.paramConfig = {"persistable": {}, "sticky": {}};
    Splunk.ViewConfig = {
        'view': {"autoCancelInterval": 90, "displayView": "home", "nativeObjectMode": "viewconf", "hasAutoRun": false, "onunloadCancelJobs": true, "canWrite": true, "id": "home", "editUrlPath": "/servicesNS/nobody/launcher/data/ui/views/home", "objectMode": "viewconf", "refresh": null, "label": "(home)", "template": "search.html", "hasRowGrouping": false},
        'app':  {"can_alert": true, "is_visible": true, "id": "launcher", "label": "Home"}
    }
        Splunk.toBeResurrected = null;
    //]]>
    </script>








            <script type="text/javascript" src="/en-US/static/@123586/js/init.js"></script>             






        <div class="splClearfix"></div>
    </body>
</html>
Tags (1)

New Member

Had exactly same response installing Splunk ver splunk-4.3.4 on Fedora. End result was to de-install/re-install. Did an strace beforehand and found some files missing with the original installation. Hope this helps...

0 Karma

Splunk Employee
Splunk Employee

Try clearing your web browser cache.

EDIT: For ambiguity...

0 Karma

Explorer

There is nothing (firewall, load-balancer) in front of the webserver. We are connecting directly to it from another machine on our LAN.

As a diagnostic, I opened a browser on the machine running Splunk, and logged in at http://localhost:8000, with the same result.

Thanks.

0 Karma

Splunk Employee
Splunk Employee

Are you hitting this server via a load-balancer? Is there something in front of your Splunk webserver?

0 Karma

Explorer

Thanks Lamar, but unfortunately that didn't make a difference.

0 Karma
State of Splunk Careers

Access the Splunk Careers Report to see real data that shows how Splunk mastery increases your value and job satisfaction.

Find out what your skills are worth!