Archive
Highlighted

App Context not working in Windows Remote Performance Monitoring

Builder

I'm creating an remote performance monitor input through Settings => Data Input => Remote performance monitoring on a Windows system. Even though I select my custom app in "App Context" while setting up the input but every time the wmi.conf file gets written to the search app's local folder. I've tried it on Splunk 8.03 and 7.3.1 and the behaviour is consistent.

I know we can manually port the stanza to app of our choice but the actual concern here is that why the option for selecting "App Context" while creating input through Splunk Web is not working.

Can somebody please verify if this is the case or I'm doing something silly?

0 Karma
Highlighted

Re: App Context not working in Windows Remote Performance Monitoring

SplunkTrust
SplunkTrust

Try selecting your custom app from the app menu before selecting from the Settings menu. You also can replace 'search' in the URL with the directory name or your app before completing the input form.

Consider filing a bug report.

---
If this reply helps you, an upvote would be appreciated.
0 Karma
Highlighted

Re: App Context not working in Windows Remote Performance Monitoring

Builder

Thanks
Yep, tried that as well but no matter what App I select it gets written to "search" app's local directory

0 Karma