Archive
Highlighted

Ansible Tower App for Splunk: Why am I receiving "unable to initialize modular input" error after install?

Communicator

Installed new app Ansible Tower App for Splunk but am seeing error:

Unable to initialize modular input "tower_app" defined inside the app "tower_app": Introspecting scheme=tower_app: script running failed (exited with code 1).

Anyone else seeing "unable to initialize modular input" after install?

Highlighted

Re: Ansible Tower App for Splunk: Why am I receiving "unable to initialize modular input" error after install?

Explorer

Hey @hlarimer, thanks for reporting this.

To fix this, I recommend downloading the 1.0.1 version of the app in Splunkbase.

The cause of the error was due to missing dependencies for the app. The dependencies are now included in later versions.

View solution in original post

Highlighted

Re: Ansible Tower App for Splunk: Why am I receiving "unable to initialize modular input" error after install?

Communicator

Thank you dsilva, app is working great now!

0 Karma
Highlighted

Re: Ansible Tower App for Splunk: Why am I receiving "unable to initialize modular input" error after install?

Explorer

I have version 1.0.1 downloaded and I'm still getting this error.
Unable to initialize modular input "tower_app" defined inside the app "tower_app": Introspecting scheme=tower_app: script running failed (exited with code 1).

From app.conf:

[launcher]
author = Red Hat Inc. ; Avocado Consulting
description = Ansible Tower App for Splunk
version = 1.0.1

0 Karma
Highlighted

Re: Ansible Tower App for Splunk: Why am I receiving "unable to initialize modular input" error after install?

Explorer

@pasito, try the latest version pushed to Splunkbase (1.0.2), that version is working for myself.

0 Karma