All Apps and Add-ons

webping is not running continuously.

ilove275
Path Finder

I downloaded the Web Page Monitor.(webping)
Monitoring check shell is running once per 30 seconds and timeout is 30 seconds.
In timechart, time series is often interrupted for 1 to 1 1/2 minutes.
And If I check the time series next day , the data is not collected.
I have to restart the webping scheduler. We have to execute the monitoring shell at every day.

That is setting files. How can I do?
Please let me know..

------------------------------bundles.conf-------------------------------

Copyright (C) 2005-2008 Splunk Inc. All Rights Reserved. Version 3.0

[webping]
author = splunk
version = 1.1
minsplunkversion = 3.3
contactemail = support@splunk.com
description = The webping bundle will peroiodically hit a webpage or series of pages and index the resultcode, time to fetch, size, and optionally the contents and/or a crc of the page
--------------------------inputs.conf---------------------------------

Copyright (C) 2005-2008 Splunk Inc. All Rights Reserved. Version 3.0

[script://$SPLUNK_HOME/etc/apps/webping/bin/webping.sh]

[script://./bin/webping.py]
interval = 30
sourcetype = webping
source = webping
index = main
disabled = false

[script://.\bin\webping.py]

interval = 30

sourcetype = webping

source = webping

index = main

disabled = false

-----------------------props.conf---------------------------------

Copyright (C) 2005-2007 Splunk Inc. All Rights Reserved. Version 3.0

[webping]
SHOULD_LINEMERGE = False
INE_BREAKER = (\nWebPingProcessor|WebPingProcessor)
LINE_BREAKER = ([\r\n]WebPingProcessor[\r\n]+)
XMUST_BREAK_AFTER = WebPingProcessor
XBREAK_ONLY_BEFORE = neverbreakshere
MAX_EVENTS = 200000
DATETIME_CONFIG = CURRENT

-----------------urls.conf--------------------------

Copyright (C) 2005-2008 Splunk Inc. All Rights Reserved. Version 3.0

[Sample URL1]

url = http://www.somehost.com

timeout = 30

userAgent = Mozilla/4.0

indexMD5 = true

[Sample URL2]

url = http://www.anotherhost.com/apage

indexResults = false

timeout = 30

indexMD5 = 1

indexResults = True

[test1]
url = http://www.test.jsp
indexResults = false
timeout = 30
indexMD5 = true

[test2]
url = http://www.test1.jsp
indexResults = false
timeout = 30
indexMD5 = True

[test3]
url = http://www.test2.jsp
indexResults = false
timeout = 30
indexMD5 = True

0 Karma

wangsimingxaxis
Explorer

I have the same issue, still searching for the answer

0 Karma
Get Updates on the Splunk Community!

Improve Your Security Posture

Watch NowImprove Your Security PostureCustomers are at the center of everything we do at Splunk and security ...

Maximize the Value from Microsoft Defender with Splunk

 Watch NowJoin Splunk and Sens Consulting for this Security Edition Tech TalkWho should attend:  Security ...

This Week's Community Digest - Splunk Community Happenings [6.27.22]

Get the latest news and updates from the Splunk Community here! News From Splunk Answers ✍️ Splunk Answers is ...